Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to configure DHCP server on Ubuntu but facing some problems. Steps I have followed are given below:

Step 1

# apt-get install dhcp3-server  

I faced following problem during installation.

check syslog for diagnostics. [fail]

Step 2

#vi /etc/default/dhcp3-server
INTERFACEs="eth1"

Step 3

#vi /etc/dhcp3/dhcpd.conf

option subnet-mask 255.255.255.248;
option broadcast-address 192.168.0.15;
option routers 192.168.0.9;   
dafault-lease-time 600;
 max-lease-time 7200;

subnet 192.168.0.8 netmask 255.255.255.248{
  range 192.168.0.10 192.168.0.14;    
}

Step 4

# /etc/init.d/dhcp3-server restart
*Stopping DHCP server dhcp3 [fail]
*Starting DHCP server dhcp3    
*check syslog for diagnostics. [fail]

I think I am missing something, what am I missing?

share|improve this question
2  
So, did you check syslog for diagnostics? Say, tail -f /var/log/syslog as you start up dhcp3-server in another terminal. –  cjc Mar 10 '12 at 3:31
    
what is the IP you have assigned to eth1 ? –  proy Mar 10 '12 at 7:30
    
There is a lot of conjections in this thread. There is a lot of info missing in the question: What's exact configuration of host ip/mask for interfaces eth1 and even what's others? Question's last report is check syslog for diagnostics, so what's dumped in this f... log!? –  F. Hauri Jul 17 '13 at 19:35

3 Answers 3

You have a small s in INTERFACEs in Step 2, is that a typo here in the question, or is that the actual file on your computer?

In Step 3 you have "dafault-lease-time" which should be "default-lease-time", so that could possibly also be the problem. Other minor details, that might be more of a cosmetical thing but should still be adjusted, is that you have a space before max-lease-time and that you lack a space between the subnetmask and {, also in Step 3.

If these pointers don't solve your problem, can you paste more of your syslog file to help us help you better?

share|improve this answer

Can you try your config like this

dafault-lease-time 600;
max-lease-time 7200;

subnet 192.168.0.8 netmask 255.255.255.248{
range 192.168.0.10 192.168.0.14;
option broadcast-address 192.168.0.15;
option routers 192.168.0.9;
}

share|improve this answer
    
netmask is already defined so an additional option subnet-mask may not be required –  proy Mar 10 '12 at 7:38

edit your '/etc/network/interfaces' configuration file and add the following:

auto eth1
iface eth1 inet static
  address 192.168.0.9
  netmask 255.255.255.0
  network 192.168.0.0
  broadcast 192.168.0.255

restart networking and dhcp via '/etc/init.d/networking restart && /etc/init.d/isc-dhcp-server restart'

If ETH1 is the internal LAN interface then it has to be setup on static IP first. I ran into the same problem when I was setting up DHCP service on one of our servers and after setting the internal LAN interface to static DHCP will then work.

share|improve this answer
1  
Can you elaborate about why you think he should make this change? –  Zoredache Mar 10 '12 at 7:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.