Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to correct the time on the Debian server. I selected my timezone in the

/usr/bin/tzselect

I select the correct continent and country, when the system asks me if the date is correct and I have to say Yes or No the time is displayed correctly, however after I confirm and check it with "date" the time does not change ie. is the same as before running timezone config.

Any suggestions?

Thanks.

share|improve this question
    
The system does not assume that everyone using it is in the same time zone the system is in. –  David Schwartz Mar 10 '12 at 10:41

3 Answers 3

up vote 2 down vote accepted

The better way is use:

sudo dpkg-reconfigure tzdata

also you can set this manually by copy one file with timezone settings:

sudo cp /usr/share/zoneinfo/Europe/Warsaw /etc/localtime

just change "Europe/Warsaw" to correct values ;-)

share|improve this answer
    
Thanks, problem solved. –  Eleeist Mar 10 '12 at 11:48

Usually, I use the following to reconfigure my timezone:

$ sudo dpkg-reconfigure tzdata

For more information, you can have a look at this page.

If your timezone is correct and you need to adjust your system clock, it is recommended to install and run ntp daemon. At least, you can use ntpdate command to update sync you clock.

share|improve this answer

You might have to log out-and-in, or just change your TZ variable.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.