Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a synology nas with an internal hdd (a 2TB wd ears). This drive has SMART errors. I took the drive and build it in a external USB case. Then i booted Linux mint and tried to mount the data partition:

$ mount -t ext4 /dev/sdc5
[ 5875.123929] EXT4-fs (sdc5): VFS: Can't find ext4 filesystem

comment-1 Here is the detailed data, it is not sdb, it is sdc5.

[ 3986.299096] scsi 3:0:0:0: Direct-Access     WDC WD20 EARS-00MVWB0          PQ: 0 ANSI: 2
...
[ 3993.436189]  sdb: sdb1 sdb2 sdb3 < sdb5 >
...    
[ 3993.519917] sd 3:0:0:0: [sdb] Attached SCSI disk

Device Boot      Start         End      Blocks   Id  System
/dev/sdc1             256     4980735     2490240   fd  Linux raid autodetect
/dev/sdc2         4980736     9175039     2097152   fd  Linux raid autodetect
/dev/sdc3         9437184  3907015007  1948788912    f  W95 Ext'd (LBA)
/dev/sdc5         9453280  3907015007  1948780864   fd  Linux raid autodetect

I tried fsck.ext4 on the device without success:

...
the superblock is corrupt, and you might try running e2fsck with an alternate superblock:
e2fsck -b 8193 <device>
...

tried this:

e2fsck -b 8193 /dev/sdc5
--> same error.

Is it possible to rebuild the filesystem without doing damage to the data?

share|improve this question

2 Answers 2

Are you sure the filesystem is on /dev/sdc? That would mean the disk would be unpartitioned with the filesystem taking up the entire disk. While that's perfectly possible, it's not that usual. Does mount /dev/sdc1 perhaps work? What does cat /proc/partitions say? Are you sure the disk shows up as sdc? If it's connected with USB, you can check the output of dmesg for instance.

share|improve this answer
1  
+1, checking dmesg output can be really helpful. Also, you can use fdisk -l /dev/sdc. –  Khaled Mar 10 '12 at 11:43
    
i can mount the other partitions, only sdc5 is not mountable –  Max Berthold Mar 10 '12 at 11:50

You seem to be having raid partitions in the /dev/sdc device. If it is a raid partition direct mount will not work. Check the output of

cat /proc/mdstat

In there you will be able to see devices like md0, md1... mdn. You should then be able to mount your raid devices via /dev/md<x>.

share|improve this answer
    
It isnt a raid, the other partitions can be mounted directly. Is there a ext4 recovery tool? –  Max Berthold Mar 10 '12 at 12:03
    
Mounting one disk/partition of a raid 1 disk should be possible. All the data is there since it's a mirror, and the metadata for mdadm is ignored. –  arjarj Mar 10 '12 at 12:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.