Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

$(subj), it appears to be what root user is denied by default for all of the shares. I'm trying to reproduce Windows administrative share.

share|improve this question

2 Answers 2

Do you have a password set in Samba (not in the system passwd file) for root ? You should be able to set such a password by running smbpasswd -a root.

share|improve this answer
    
Slap forehead, vote up and accept! I completely forgot what there is no common AAA in the Linux! –  user539484 Mar 13 '12 at 13:30

You should be putting up your smb.conf so that we can actually assess the problem. Anyway here's a hint:

   invalid users = root

is part of the default smb.conf.

Well then. Is root a valid smbuser, yet? Then try explicitly allowing root :

valid users = root 

And try something like this:

[config]
    comment = Admin Config Share  - Whatever
    path = /
    valid users = someusers, somegroup
    force user = root
    force group = root
    admin users = someusers, somegroup   
    writeable = Yes
share|improve this answer
    
Does it have to be explicitly specified option or implicitly assumed? My smb.conf isnt "from-scratch" and does not contain any valid users or invalid users parameters at all. –  user539484 Mar 10 '12 at 16:24
    
Hmm, also, according to doc there is no invalid users by default. –  user539484 Mar 10 '12 at 16:46
    
See edited post. –  juwi Mar 10 '12 at 16:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.