Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to get xcache 1.3.2 installed on my centos 5.8final (64bit) machine. It's running nginx 1.1.13 and php 5.4.0.

This is the output of ./configure --enable-xcache --with-php-config=/opt/php/bin/php-config

http://pastebin.com/YWVyna1S

Seems to be going OK, but when i want to make it, it shows this error: make: *** [processor.lo] Error 1

Full output here of make.

http://pastebin.com/Sz1k2Jzq

Any idea how to resolve this?

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

XCache currently does not support PHP 5.4.0 as the API changed, latest supported is 5.3.10.

http://xcache.lighttpd.net/ticket/271

On a side note. I also can't APC to compile on PHP 5.4.0, so giving it a bit of time before you upgrade might be a good idea.

share|improve this answer
    
Ok that makes sense. I will revert back to 5.3.9 –  Mr.Boon Mar 11 '12 at 15:06
    
You should revert to 5.3.10. 5.3.9 has a security issue. –  Martin Fjordvald Mar 12 '12 at 3:42
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.