Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm trying to do P2V with a Debian powered-on source. Everything works perfectly up until the point of selecting destination.

It states that the destination type is VMware Infrastructure virtual machine.

It asks for the server details and along the right it states that supported VMware Infrastructure products include VMware vCenter Server 2.0, 2.5 and 4.0. Great, I thought, because I'm running VMware vCenter Server 4.0.1 on this machine.

So I try to specify the details of my machine but I get any one of a few errors:

  • Timeout
  • Unable to recognise the server type or version
  • Target machine actively refused the connection

What confuses me the most is that I'm using the same details of the server I connected to in the first place, therefore I know that it can connect to the server and it is running.

The server is running on my laptop, the agent is running on the Linux machine. I get this same error whether I use the client on my laptop or the Linux machine itself!

Any ideas? Do I need another product running to be the 'destination'?

share|improve this question
    
what converter version are you running? –  the-wabbit Mar 11 '12 at 19:33
    
"because I'm running VMware vCenter Server 4.0.1 on this machine." –  deed02392 Mar 11 '12 at 20:54
    
The version of your vCenter Server is not (necessarily) the version of the vCenter converter. –  the-wabbit Mar 12 '12 at 12:16
    
You're right, that is because there is a difference between VMware vCenter Converter Server and VMware vCenter Server (which I have just discovered), which probably explains the issue. –  deed02392 Mar 12 '12 at 13:14
1  
Since you are just converting a single machine and do not need any of the automation features provided by the vCenter Server integration, consider using the vCenter Converter Standalone (latest version is 5.0 currently) which is downloadable from the vmWare website. –  the-wabbit Mar 12 '12 at 17:25

2 Answers 2

up vote 1 down vote accepted

The problem is that you are converting a linux based server, those can only be done to an ESX/ESXi machine. What I did to get mine done was download the free ESXi 4 from vmware then install that on a VM, its quick to do. Then you use that as your destination. After that its pretty simple to do the conversion.

share|improve this answer
    
I finally got it to work using this method. I downloaded ESXi 4 from VMware (the latest version is 5, but vCenter Converter doesn't specify it supports that, though that may be because I accidentally downloaded an older version). This thread describes my process: communities.vmware.com/message/2033784 I only needed to access SSH on the Linux server and there's no need to install anything on it. –  deed02392 May 3 '12 at 9:11

vCenter Converter gave me headaches, I just booted the bare metal machines with Clonezilla, created an image, and then booted the intended guest with Clonzilla and restored the image inside of the guest.

share|improve this answer
    
I love to do that Tim, but this is a rack server I'm leasing from a colo in another country! It's look like I need another computer to run an OS compatible with VMware vCenter Server, then it should work. I will post back if I'm successful. –  deed02392 Mar 16 '12 at 17:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.