Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to figure out the exact mkisofs cmd to create the ISO with the following directory and file structure. I've tried different commands, but when I mount the ISO that is created the directory tree has not been reproduced.

The initial directory tree is:

master.iso::
mount -o loop /apps/vmware/master.iso /mnt/vmtest


ls /mnt/vmtest
isolinux ks.cfg upgra32 upgra64 upgrade.sh

ls /mnt/vmtest/isolinux
boot.cat initrd.img isolinux.bin isolinux.cfg vmlinuz

I've used different variations of the following mkisofs command without success:

mkisofs -o '/foo/test.iso' -b 'isolinux.bin' -c 'boot.cat' -no-emul-boot  -boot-load-size 4 -boot-info-table 'isolinux'

How do I make an ISO that captures a directory's exact structure?

share|improve this question
    
Have you tried the genisoimage package ? –  AndyM Mar 28 '12 at 21:27
    
What is generated? –  MikeyB Mar 29 '12 at 2:02
add comment

1 Answer

Where are you running the mkisofs command from? Have you tried specifying absolute paths? e.g.:

 mkisofs -o '/foo/test.iso' -b '/mnt/vmtest/isolinux/isolinux.bin' -c '/mnt/vmtest/isolinux/boot.cat' -no-emul-boot  -boot-load-size 4 -boot-info-table /mnt/vmtest
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.