Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a website on a shared server with fatcow.com. We purchased a Quick Geotrust SSL for our site through fatcow and once it was installed on our site we tried it. Howeever, when we go to https://example.com we still get an error showing the shared SSL from fatcow. We contacted them and they said that we need to point our domain through our DNS to the SSL IP address which is different from our shared server IP. Wouldn't this change in IP address disable our site? Is this because the SSL needs a dedicate IP... ? Not sure what do do and don't want to break the site down.

Any help would be greatly appreciated.

share|improve this question
add comment

2 Answers 2

The server has an IP address that is shared by every site on the server. It also has an IP address that is just yours. If you want SSL to work, you'll need to point the DNS name you want it to work for to the IP address that's just yours.

If you're worried that it might not work, point your browser at the IP address using an https:// prefix. If you get a site on that machine, but with a certificate error, it's working.

share|improve this answer
    
Thanks David. So I pointed the browser at the IP address with the HTTPS:// prefix. I got the certificate error saying that the certificate belongs to our site (our domain name), but when I went ahead to proceed to the site, I got a "403 Forbidden" error, no site...does that mean that it is not working? or did I miss something? Thanks. –  Frank Mar 12 '12 at 5:00
    
It could, but it could also mean the web server needs the site name as well as the IP address to find your site. –  David Schwartz Mar 12 '12 at 19:21
add comment

The SSL version of the site is likely served by a different IP-based virtualhost than the non-SSL site.

You can test this by just putting the following in your hosts file and the browsing to example.com

10.3.4.5  example.com

(of course replace 10.3.4.5 with the SSL IP fatcow gave you)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.