Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We just moved to a new server, and our page sometimes doesn't load. When I check Inspect elements, and look at the network tab, some element gets cancelled and sometimes the entire pages fails to load.

I am quite new to this, and never seen this sort of behaviour before. Anyone has any tips to pinpoint the problem ?

share|improve this question
    
Welcome to ServerFault! I see that you have a 12% accept rate. It's likely you won't get a lot of responses to your questions with a low accept rate. Choosing correct answers is how folks are rewarded for their time. Please revisit your previous questions and accept an answer if possible. If you haven't received a satisfactory answer, consider updating the original question with some more information. –  Kyle Smith Mar 12 '12 at 12:59
    
Oh, ok. cheers ! –  Katafalkas Mar 12 '12 at 16:05
add comment

1 Answer

up vote 1 down vote accepted

Certainly: obtain the web server error and access logs and compare those with what you requested.

share|improve this answer
    
I run nginx on the front end the apache at the back. As in, nginx is listening on the port 81, and redirecting everything to port 80. apache is listening on the port 80. Ip tables is redirecting all incoming traffic from port 80 to 81. So its like 80-iptables->81-nginx->80-apache->content –  Katafalkas Mar 12 '12 at 9:28
    
I will grep the name of the element that failed/canceled from the apache and nginx error logs. –  Katafalkas Mar 12 '12 at 9:32
    
So i have checked, and none of the error logs have any record of that picture that did not load. –  Katafalkas Mar 12 '12 at 9:35
    
This seems unnecessarily convoluted; I would suspect the nginx proxy if there is nothing in the apache error logs. –  adaptr Mar 12 '12 at 9:43
    
I have changed nginx logs to debug, expecting to find anything that causes it. I have also increased nginx workers, but nothing changed. Still no idea why the problem occurs. –  Katafalkas Mar 12 '12 at 10:44
show 2 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.