Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We own a Linux VPS Server with Virtuozzo container and qmail mail server, we have changed our webmail client from Horde to roundcube a while ago. Then we switched back to Horde client.

Now when we send emails from webmail, mails are seem to be sent but the problem is that none of them reaches to the recipients and we get no feedback.

We tried with both Horde and Roundcube but nothing is changed.

E-mails are being sent succesfully from my cellphone, outlook and gmail with our server's smtp settings.

Which settings I should check or what can I do to find out what is causing to this problem.

I would appreciate if you could show me a way.

Thanks in advance

////EDIT////

After some more research in maillogs I realized that some characters are being added to the recipient's address

Mar 13 09:27:51 sunucu qmail-queue-handlers[30654]: recipient[6] = 'onurkucukkece@gmail.comâ€'

but if I add a cc and bcc addresses then those characters are being added only to the last address.

Mar 13 17:12:11 sunucu qmail-queue-handlers[1973]: recipient[6] = 'onurkucukkece@dortgoz.com'
Mar 13 17:12:11 sunucu qmail-queue-handlers[1973]: handlers dir = '/usr/local/psa/handlers/before-queue/recipient/onurkucukkece@dortgoz.com'
Mar 13 17:12:11 sunucu qmail-queue-handlers[1973]: recipient[7] = 'onurkucukkece@gmail.com'
Mar 13 17:12:11 sunucu qmail-queue-handlers[1973]: handlers dir = '/usr/local/psa/handlers/before-queue/recipient/onurkucukkece@gmail.com'
Mar 13 17:12:11 sunucu qmail-queue-handlers[1973]: recipient[8] = 'nerdenbileyimyaa@hotmail.comâ€'
Mar 13 17:12:11 sunucu qmail-queue-handlers[1973]: handlers dir = '/usr/local/psa/handlers/before-queue/recipient/nerdenbileyimyaa@hotmail.comâ€'

I believe those characters are causing the problem but I have no idea why they are being added

share|improve this question

1 Answer 1

It is quite hard to answer the question in any meaningful way without further data. It seems though that it is probably some misconfiguration with your web clients.

You need to check the relevant log files, to start with, to see if any errors appear there.

The Qmail log files are usually located at /var/log/qmail and you are looking for qmail-smtp/log. If you are using something like Plesk the log files are in /usr/local/psa/var/log/maillog

Also check for php errors. Check /etc/php.ini file for the location of that file even though it usually is in /var/log/httpd/error.log

share|improve this answer
    
thank you @thanosk. I checekd the maillog and I realized that some characters are added to the recipients' address. Here is a line from maillog. Mar 13 09:48:54 sunucu qmail-queue-handlers[5853]: recipient[6] = 'onurkucukkece@gmail.comâ€' is that normal or might be the cause of the problem? –  Onur Mar 13 '12 at 7:56
    
I realized that those characters evolves to double quote –  Onur Mar 13 '12 at 8:15
    
No the quotes are just the way Plesk writes things in the log file –  thanosk Mar 13 '12 at 12:09
    
I mean †evolves to double quote which comes right before the single quote. Now I added a cc and bcc addresses to the mail then those characters are added only to the bcc address and the first 2 recipients get the mail. –  Onur Mar 13 '12 at 15:31

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.