Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've got a funny problem connecting to an AOS server.

I got a domain network containing a (VM) Server running the Application Object Server (AOS).

Client computer A) can connect to the AOS without problems and work.

When client computer B) tries to connect, all I get is this error message: Logon Error
Connection with the Application Object Server could not be established.

The event log of Client B) does not contain any messages about this.
Firewalls are off on all three computers (by GP).
Tcp/ip from cliebt B) to the AOS server does run fine.
Both clients run the same OS (win 7 RC), sit on the same subnet, next to each other. Yesterday it all worked, today just one computer can connect.

Any ideas what might cause this problem, how to resolve it, or how to debug it?

share|improve this question

3 Answers 3

Problem may be with stored credentials in Windows 7.

Clear appropriate credentials under: Control Panel\All Control Panel Items\Credential Manager.

share|improve this answer
    
Thank you very much. This did the job. I've tried everything previously, from altering the configurations in the win registry, flushing dns, deleting auc files, altering the hosts file and even reinstalling the client but only clearing the credentials does the job. Regards, Viktor –  user91874 Aug 17 '11 at 14:12

This worked for me under Windows 7:

Control Panel >> Administrative Tools >> Services >> Search on " Dynamics Ax " and click " play Button " ( coloured Green ) in the tool bar ..

Should do the trick!

share|improve this answer
    
This would start the service, if it is not started? –  Sam Sep 12 '11 at 7:24

My apologies for resurrecting a dead post, but did you ever find the root cause of this problem?

The first thing I would check would be that the Ax Client configuration Connection settings are correct.

The only time I've seen an error remotely close to what you describe on an AOS that is up and working is when users are not connecting with a shared client configuration file and the active configuration on the client throwing the error is identical in all respects save that of the AOS port number assignment.

For example: AOS Server is configured on port 2712 (the default)

Client A -> Configured to connect to AOS on port 2712

Client B -> Configured to connect to AOS on port 2714

share|improve this answer
    
Nope, never found the root cause. Client configuration was good, though. –  Sam Apr 1 '10 at 8:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.