Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

When I configure a new domain using Webmin/BIND, I am asked for a Master Server. Webmin fills this value automatically with the hostname of my box. However, this hostname is made up and there is no DNS already defined for the box other than Google public DNS 8.8.8.8, 8.8.4.4. So, I believe that my issue is that when looking for NS record for every new zone, BIND fails because it cannot resolve the NS. How do I define my hostname in BIND so that it can resolve?

Result of dig @localhost emprod ns

[root@emx0 ~]# dig @localhost emprod ns

; <<>> DiG 9.7.3-P3-RedHat-9.7.3-8.P3.el6_2.2 <<>> @localhost emprod ns
; (2 servers found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 33828
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

;; QUESTION SECTION:
;emprod.                IN  NS

;; AUTHORITY SECTION:
.           10800   IN  SOA a.root-servers.net. nstld.verisign-grs.com. 2012031300 1800 900 604800 86400

;; Query time: 6 msec
;; SERVER: ::1#53(::1)
;; WHEN: Tue Mar 13 10:04:09 2012
;; MSG SIZE  rcvd: 99

Updated config for zone emprod below.

//
// named.conf
//
// Provided by Red Hat bind package to configure the ISC BIND named(8) DNS
// server as a caching only nameserver (as a localhost DNS resolver only).
//
// See /usr/share/doc/bind*/sample/ for example named configuration files.
//

options {
    listen-on port 53 { 127.0.0.1; };
    listen-on-v6 port 53 { ::1; };
    directory   "/var/named";
    dump-file   "/var/named/data/cache_dump.db";
        statistics-file "/var/named/data/named_stats.txt";
        memstatistics-file "/var/named/data/named_mem_stats.txt";
    allow-query {
        10.1.1.0/24;
        192.168.10.0/24;
        10.2.1.0/24;
        };
    recursion yes;

    dnssec-enable yes;
    dnssec-validation yes;
    dnssec-lookaside auto;

    /* Path to ISC DLV key */
    bindkeys-file "/etc/named.iscdlv.key";
    forwarders {
        8.8.8.8;
        };
};

logging {
        channel default_debug {
                file "data/named.run";
                severity dynamic;
        };
};

zone "." IN {
    type hint;
    file "named.ca";
};

include "/etc/named.rfc1912.zones";

zone "emprod" {
    type master;
    file "/var/named/emprod.hosts";
    };

$ttl 38400
emprod. IN  SOA emx0.emlocal. admin.emergingmed.com. (
            1331589041
            10800
            3600
            604800
            38400 )
emprod. IN  NS  emx0.emlocal.
share|improve this question
    
Are you trying to set it up as authoritative for your domain(s), or as a recursive resolver? What's the config look like now? –  Shane Madden Mar 12 '12 at 21:38
    
Authoritative... please let me know which config I should post. I'll start posting some now. –  tacos_tacos_tacos Mar 12 '12 at 21:38
    
What behavior are you seeing? It's configured to only listen on the localhost address - so, can you successfully query records from that system itself (dig @localhost emprod ns)? If not, what error do you get? –  Shane Madden Mar 13 '12 at 1:17
    
Posted the results of dig @localhost emprod ns –  tacos_tacos_tacos Mar 13 '12 at 14:04
    
Have you restarted the BIND service since the zone was added? Does it log any errors during its start? –  Shane Madden Mar 13 '12 at 15:20
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.