Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Redirect has been working fine to when users connect to http://owa.company.com they get redirected to a log in page at https://owa.company.com/owa. It's just using the redirect setting in IIS. Then today I created a new ssl certificate and replaced the old one on this Exchange server. Now, I can connect directly to https://owa.company.com/owa just fine and it shows it is using the new certificate, however if I go to http://owa.company.com then I get a 403 http error.

It does work if I go to https://owa.company.com, then it will still redirect to the /owa site, but if I use plain http, then I get the errror.

I'm stumped!! I've tried unchecking the redirect setting, restarting IIS and re-enabling the redirect setting, which did no good. Everything else I've found with googling either has no solution or just gives instructions for enabling the redirect setting.

Again: this was working fine until I renewed the ssl certificate.

share|improve this question
    
As a workaround, I have disabled the "require ssl" rule on the default site, which then lets the redirect happen. –  James Mar 14 '12 at 13:11

1 Answer 1

Exchange likes to set "SSL Required" on the IIS Web Site, which will cause this error for HTTP. Check the info under "For a Configuration in Which SSL is Required on the Default Web Site":

http://technet.microsoft.com/en-us/library/aa998359(v=exchg.80).aspx

share|improve this answer
    
Those are the instructions I followed. That is how it is setup. It's almost like it is hitting the "require ssl" rule before it is hitting the "redirect" rule. –  James Mar 14 '12 at 13:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.