Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Is there a way to by-pass the gpgcheck when using the repo command in a kickstart file?

I'm trying to define the repository to use for "package" installation.

At the moment on install, the first package it tries to grab is, "iputils-20071127-16.el6.i686.rpm".

It appears to transfer ok, but then displays the error,

"The file cannot be opened. This is due to a missing file, a corrupt package or corrupt media....".

I'm assuming this is a gpgcheck error, or a checksum error.

UPDATE

On the VM I'm installing into I managed to drop to console after the error occurred, transfer the file manually via wget, and confirm that the hash matches the hash listed for the package in filelists.xml.

However, on running rpm -K iputils-20071127-16.el6.i686.rpm I get the message:

iputils-20071127-16.el6.i686.rpm: RSA sha1 ((MD5) PGP) md5 NOT OK (MISSING KEYS: (MD5) PGP#c105b9de)

So this appears to be the issue with the "corrupt error" showing up on installation. Can this check be disabled?

NOTE:

I've confirmed the file is ok by transferring it via the same transfer method and installing it via command line on a separate VM.

kickstart file

install
url --url http://192.168.240.79:8008
lang en_US.UTF-8
keyboard us
xconfig --startxonboot
network --device eth0 --bootproto dhcp
rootpw --iscrypted $1$CVbGwMaJ$.
firewall --enabled --port=22:tcp
authconfig --enableshadow --enablemd5
selinux --disabled
timezone Asia/Tokyo
bootloader --location=mbr --driveorder=sda --append="rhgb quiet"
repo --name="Local-Repo"  --baseurl=http://192.168.240.79:8008/ --cost=100

%packages
@base
@core
@custom-shared
@custom-db
%end

filename

share|improve this question
    
Can you post your kickstart cfg file? –  MadHatter Mar 13 '12 at 8:42
    
Thanks for that. Your assumption is reasonable, but it's also an assumption. You have checked that the package file in question isn't corrupt on the server, haven't you? –  MadHatter Mar 13 '12 at 8:55
    
I transferred the "problem" file using the same transfer method to a separate VM and it installed ok. –  monkut Mar 13 '12 at 8:58
    
And just ran "rpm -K iputils.." on the transferred file and it came out OK –  monkut Mar 13 '12 at 9:01
add comment

1 Answer

up vote 2 down vote accepted

Ok, this is obscure, but let me post what I found in case someone else hits this.

For the HTTP server I was trying to use the python built-in SimpleHTTPServer. This worked fine downloading the initial image and other files, but would always return a "corrupt" error when it hit the first RPM.

It turns out this is because the SimpleHTTPServer does not support Range requests.

(See https://bugzilla.redhat.com/show_bug.cgi?id=624431)

After finding this out, I found that someone had already made a version of SimpleHTTPServer that supports Range, https://github.com/smgoller/rangehttpserver.

After dropping in RangeHTTPServer for SimpleHTTPServer installation proceeds as expected.

share|improve this answer
    
thank you so much for digging (and following) this up. This happens also, if you have disabled range in Apache httpd due CVE-2011-3192, eg. "RequestHeader unset Range". –  user150645 Dec 22 '12 at 4:00
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.