Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm running Ubuntu 10.04 with latest updates.

Here are my system's protections for lp and lpr.

root@steamboy:/usr/bin# ls -l lp
-rwxr-xr-x 1 root root 13540 2011-09-12 10:41 lp
root@steamboy:/usr/bin# ls -l lpr
-rwxr-xr-x 1 root root 13540 2011-09-12 10:41 lpr

Only if I sudo can I print something at the command line, else I can unauthorized.

I do have an smb printer with username and password embedded, but I believe this problem occurred during one of the 10.04 updates. So my question is what would cause lp or lpr to return Unauthorized?

ics@steamboy:~/icsdev$ lp x.tmp
lp: Unauthorized
ics@steamboy:~/icsdev$ lpr x.tmp
lpr: Unauthorized

(x.tmp is a real file.)

The real stumper is gedit will allow me to print.

share|improve this question
    
Is selinux enabled? What are the selinux restrictions on lp, lpr, and the associated files? (ls -Z) –  mpez0 Apr 3 '12 at 18:04
    
I believe it is not enabled. I did not install it, and there is no /etc/selinux directory. Also, the "unauthorized" message started happening after an update. –  octopusgrabbus Apr 3 '12 at 18:41

1 Answer 1

up vote 2 down vote accepted

try checking your printers.conf file and comment out the line:

AuthInfoRequired negotiate

it's a default setting in ubuntu

share|improve this answer
    
hmm maybe you could check the cups.conf file and check for local user printing permissions. also, it could be that the user trying to print doesnt have read permissions to the cups.conf file. if so, chmod 644 /etc/cups/client.conf . gl! –  3a2roub Mar 13 '12 at 18:02
    
AuthInfoRequired not present in printers.conf –  octopusgrabbus Apr 3 '12 at 16:01
    
/etc/cups/client.conf not present. –  octopusgrabbus Apr 3 '12 at 16:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.