Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have just down graded my PHP-installation from 5.3.9 to 5.3.3. This in order to be able to use yum/EPEL instead of compiling everything myself.

Appearently, mysqlnd-support isn't available in 5.3.3 and since I don't want to compile the source myself anymore, I cannot just add it during that phase.

I would like to use yum/EPEL, but there seems to be no package for mysqlnd available yet.

Any suggestions for how to do this (other than re-programming the application)?

share|improve this question
    
The mysqlnd driver is built in to 5.3 as standard? –  Ben Lessani - Sonassi Mar 23 '12 at 1:42
    
Nope (at least not for me...), but you have the links where you can get it from here: blog.famillecollet.com/pages/Config-en (this works with 5.3.3). @cjc has some suggestions as well, the answer is updated after I solved my problem so I haven't tried that actual solution. Please note that if you use my link that repository is not searched by default when you do some yum-activity, don't remember how to include it but it's on their page somewhere. –  Nicsoft Mar 24 '12 at 14:17

1 Answer 1

up vote 1 down vote accepted

The module is in Atomicorp's RPM repostiroy:

http://www6.atomicorp.com/channels/atomic/centos/6/i386/RPMS/

You will probably need to do a package upgrade to 5.3.9 using their reposistory. Take a look at http://www.atomicorp.com/downloads.html for the shell script that will install and activate that repository.

share|improve this answer
    
Thanks again cjc, this was some related problem to the change to EPEL that you helped out with. It worked fine using the repo and yum. –  Nicsoft Mar 13 '12 at 17:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.