Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Have an HP ProLiant ML110 G7 running Server 2008 R2.

Question #1:

This server takes FOREVER to boot. I think it's because of "HP Power and Thermal Calibration" it does at the beginning of every boot. Is this necessary, and if not, can disable it to speed up the boot times?

Question #2

Occasionally, the server tries to boot off the network for some reason, but this ONLY happens if there's an external USB hard drive plugged in (which we use for backups). Gets pretty annoying after rebooting and then finding its sitting there trying to boot off the USB Drive. I've tried digging thru it's "BIOS" but haven't found anything that looks like what I want (Change boot order?). Any ideas on this one?

Thanks!

share|improve this question

4 Answers 4

up vote 5 down vote accepted
  1. No it's not, feel free to disable it.
  2. Change the boot order in the BIOS setup (F9), it's in there, ensure they're in the right order you need.
share|improve this answer
3  
Also note, if you really don't need to boot from Network/USB etc. You can disable the feature in the boot order instead of just prioritizing it down. –  NcA Mar 13 '12 at 18:32
    
How do you disable power calibration? –  ewwhite Jan 11 '13 at 13:17

Change boot order in the BIOS to make the computer boot from hard disk before USB devices.

share|improve this answer
    
I looked all over in the BIOS, but couldn't find anything that looked like "Boot Order". It's BIOS is unlike any I've ever seen... –  David Mar 13 '12 at 17:17
  • You won't be able to change the speed with which the machine goes through its POST process.

  • As for the boot order, you can set it in the BIOS (ROM-based setup utility) under: Boot Settings Configuration -> Standard Boot Order

share|improve this answer

OK, this may sound crazy, but I just stumbled upon a solution that worked for me...I realized that the ONLY physical change I had made to this server in recent memory was moving the USB mouse & keyboard cables from the front controller to the back. On a wild hunch, I decided to unplug both WHILE THE SERVER WAS HUNG at the "HP Power and Thermal Calibration" screen. Almost immediately, the server completed the calibration, POST continued, and the server booted properly. Have not had a problem since.

Since I really don't want to go looking for trouble, I am simply never going to use the rear USB ports again (I have plenty on the front anyway). So, if anyone wants to investigate that angle further, keep my solution in mind!

Hope it helps at least one person!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.