Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I host my emails on Google Apps. I have three domains there.

The problem is every single email I send from any of these domains, when sent to gmail, are marked as spam.

  • I have configured the SPF entries, and they all include a txt entry with ~all
  • I have checked blacklists and my domains/ip are not included there.

  • I have also tried using the smtp option on Google apps using or the native option.

Both options do not work.

Any ideas?

share|improve this question
When mail from your domain hits my server, I do a lookup to see if the name and the IP match. If they don't, I reject the mail as spam. Check PTR (rDNS) for MX. – goblinbox Mar 14 '12 at 1:28
up vote 2 down vote accepted

It seems I have found the answer.

Gmail does not like having two "include" entries on the SPF.

I had two servers there, and noticed that although all spam checkers/blacklist passed, told me the SPF as "Error while analyzing SPF data"

I removed one and left only the google one, and it seems to be working now

share|improve this answer
 v=spf1 a mx ~all

Which is a bit different than what Google says. Add this and It will work fine now.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.