Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

we have a dv server with mediatmeple, running apache 2.2, and plesk panel 10.3.

for some reason, when sending mail from our domain to theirs, or when they send email to ours, the messages bounce back with the 'retry timeout' error.

before messages bounce back which we send out to this domain, i see them stuck in the mail queue in plesk panel:

example of info in bounced message:

> > Subject: Mail delivery failed: returning message to sender
> > 
> > 
> >> This message was created automatically by mail delivery software.
> >>
> >> A message that you sent could not be delivered to one or more of its
> >> recipients. This is a permanent error. The following address(es) failed:
> >>
> >>
> >> retry timeout exceeded
> >>
> >> retry timeout exceeded
> >>
> >> ------ This is a copy of the message, including all the headers. ------
> >>
> >> Return-path: <>
> >> Received: from 
> >> ([] helo=sales)
> >> by with smtp (Exim 4.69)
> >> (envelope-from <>)
> >> id 1S7Uvm-0008KS-3q; Tue, 13 Mar 2012 12:50:38 -0400
> >> Message-ID: <872EF71E95BA453EA0F8870024C3A22A@sales>
> >> From: "Claudio D'Ulisse" <>
> >> To: "Errol Rosario" <>,
> >> "MIKE BERG" <>
> >> Subject: test
> >> Date: Tue, 13 Mar 2012 12:50:31 -0400
> >> MIME-Version: 1.0
> >> Content-Type: multipart/alternative;
> >> boundary="----=_NextPart_000_00E0_01CD0117.DFCD9440"
> >> X-Priority: 3
> >> X-MSMail-Priority: Normal
> >> Importance: Normal
> >> X-Mailer: Microsoft Windows Live Mail 14.0.8117.416
> >> X-MimeOLE: Produced By Microsoft MimeOLE V14.0.8117.416
> >>
> >> This is a multi-part message in MIME format.
> >>
> >> ------=_NextPart_000_00E0_01CD0117.DFCD9440
> >> Content-Type: text/plain;
> >> charset="iso-8859-1"
> >> Content-Transfer-Encoding: quoted-printable
> >>
> >> can you confirm you get this email please?

the maillog (/usr/local/psa/var/log/maillog) see log

a quick dns report - anything vital on there in need of attention?

SOLVED- response from Media Temple support:

Checking the domain names for an MX lookup, the IP address that was returned was on our blacklist due to malicious activity. As there has not been any recent malicious activity from this IP address, we were able to remove the ban. You should be able to receive email from / now. Please verify.

If you have any further questions regarding your (mt) Media Temple services, please feel free to contact us at any time.

Best Regards,

Customer Support (mt) Media Temple 877-578-4000 310-564-2007 (mt) Current System Status: (mt) User Forums: Follow us on Twitter!

share|improve this question
Hire good postmaster? – Lazy Badger Mar 14 '12 at 0:59
@Lazy Badger a thought. – vulgarbulgar Mar 14 '12 at 1:03
And hostmaser also – Lazy Badger Mar 14 '12 at 1:04
Can you post errors from the server logs as well? This error is non-verbose and pretty useless. – goblinbox Mar 14 '12 at 1:20
@goblinbox just updated the question with a link to a paste of the maillog – vulgarbulgar Mar 14 '12 at 1:34
up vote 2 down vote accepted

Start from fixing IN PTR records for MX-hosts (they are domain-emitters also, yes?!)

Shit 1 -

Quering for {,ANY}
Received answer from
  Not authoritative

Answers for
  -> [PTR]

Shit 2 -

Quering for {,ANY}
Received answer from
  Not authoritative

Answers for
  -> [PTR]

But now

Mar 13 02:45:09 floridaseating qmail: 1331621109.213098 starting delivery 1217: msg 33459587 to remote *
Mar 13 02:46:10 floridaseating qmail: 1331621170.273121 delivery 1217: deferral: Sorry,_I_wasn't_able_to_establish_an_SMTP_connection._(#4.4.1)/

show us banal troubles of connectivity

Cheap solution

Find SMTP-server, from which both sides are SMTP-reacheable and build backup-MX for domains on it. Deferred on delivery to primary MX will be dropped to backup-MX and later from it - on primary

share|improve this answer
how's looking? the only other domain we have an issue with, so far... – vulgarbulgar Mar 14 '12 at 1:43
@vulgarbulgar - same hoster as for sitconf, same shit in PTR (* for emitter/collector – Lazy Badger Mar 14 '12 at 1:55
ah, so it'd explain why. thank you! – vulgarbulgar Mar 14 '12 at 2:27
i'm trying to educate myself on how to correct this. i ran a PTR test ( and seem to get a positive result, though i'm not sure how conclusive that is: – vulgarbulgar Mar 14 '12 at 3:15
@vulgarbulgar - two ways: a) change IN PTR in reverse-zone to names from forward-zones b) change MX names in forward zones to * hosts. Anyway, it does not solve (must not) timeout troubles – Lazy Badger Mar 14 '12 at 3:54

I would find it strange for a setup to block the SMTP handshake/connection based on reverse dns.

Can you please clarify some information?

Your bounceback email states the mail was attempting to be sent TO FROM and failed. Yet your image of the queue shows mail being sent FROM TO Also your qmail maillog shows you as

Do you manage both parties? It's rare for the problem to be seen both ways without one side having more issues than just email to or from one domain. Can you verify the direction the problem is happening in (even tho you mentioned once it was happening both ways).

THIS-> Based on what I can see it appears might not be setup correctly. It is currently stating the MX server resolves from's host record: though this shows as the reverse DNS. In my first test it reported that it didnt like the RCPT In the more recent test it stated there was a local problem Also one host got blocked because of reaching its limits.

I'd focus my efforts on that server and why it's throwing errors.

share|improve this answer
i represent, and only manage (learning to) that server. the problem consistently exists both ways, when sending and receiving from or – vulgarbulgar Mar 14 '12 at 4:54
"I would find it strange for a setup to block the SMTP handshake/connection based on reverse dns" - I think, they are unrelated issues. I assumed RDNS-rejects before reading logs, now 1-st class trouble is poor connectivity – Lazy Badger Mar 14 '12 at 6:38

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.