Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to install nginx from source, with nginx upload module included. However I'm running to this weird error:

./configure --with-http_ssl_module --with-http_flv_module --with-http_gzip_static_module --with-mail --with-mail_ssl_module --with-poll_module --with-http_stub_status_module  --with-http_perl_module --add-module=/root/dls/nginx_upload_module_2.2.0
...
**adding module in /root/dls/nginx_upload_module_2.2.0
./configure: error: no /root/dls/nginx_upload_module_2.2.0/config was found**

while config is definitely there:

root@xxxxx:~/dls/nginx-1.1.14# l -alh /root/dls/nginx_upload_module-2.2.0/config 
-rw-r--r-- 1 1000 1000 188 2010-09-27 14:54 /root/dls/nginx_upload_module-2.2.0/config

How can I fix this to get nginx installed?

share|improve this question
    
Perhaps just a typo in your post - but the error path has an underscore (nginx_upload_module_2.2.0), while the path your config is in uses a dash (nginx_upload_module-2.2.0). –  cyberx86 Mar 14 '12 at 2:11
    
thank you! it wasn't a typo in my post, but it was indeed a typo in the ./configure command... –  Thi Duong Nguyen Mar 14 '12 at 4:29

1 Answer 1

up vote 0 down vote accepted

From the information provided, it would appear that the path specified in the configure command has an underscore (nginx_upload_module_2.2.0), while the actual path to your config has a dash (nginx_upload_module-2.2.0). Since they do not match, the config legitimately cannot be found by the configure command.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.