Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am a complete Linux newbie, but we have quite a few spare Dedicated Machines available right now, so I decided to setup CentOS 6.2 on one of them and start getting more familiar with it. Obviously the first step after install is to configure the NIC, however I am having a lot of trouble getting it working.

I used the instructions from HERE and the IP Address block assigned to this machine is

Here are my settings, and I made sure to reset after making all of the changes. Is there something wrong with any of them I am missing?






share|improve this question
It looking good – neolix Mar 14 '12 at 12:02
I can't ping the IP Addres, I can't ping other machines, etc. I get "ping: unknown host" or "connect: Network is unreachable" if I ping by IP Address. – Brett Powell Mar 14 '12 at 12:05
have you service network restart and try the same. – neolix Mar 14 '12 at 12:08
Can you post the output of ifconfig -a after the reboot? netstat -rn would also be useful. – MadHatter Mar 14 '12 at 12:08
netstat -rn shows "Dest: Gateway: Genmask: Flags: U MSS:0 Window:0 irtt:0 Iface:etho0" – Brett Powell Mar 14 '12 at 12:11
up vote 2 down vote accepted



Set that as your ifcfg-eth0. The Directive for the IP Address is actually "IPADDR". The GATEWAY should be defined in this config file, and BOOTPROTO set to none. Also remember that if you're using "quotes" after the = to keep them consistent across the config file.

A couple more basics...

  • Enter your IP and hostname in /etc/hosts
  • In the terminal type:


share|improve this answer
Thank you! I set it exactly as instructed, removed the GATEWAY=x.x.x.x from "etc/sysconfig/network". I realized I was using eth0 but it should have been eth1. It seemed to start working (atleast delayed the errors) but still no luck. I think I have more issues than I realized though, so I will just accept this and keep tinkering. – Brett Powell Mar 14 '12 at 13:29
Did you reset the network service after making the changes? I noticed you're using public IPs. Do you have a block allocated to you? And are the gateway/netmask settings correct? – NcA Mar 14 '12 at 13:31
Actually I just gave it one more shot using eth0 and it worked. The rest of our machines seem to be configured to use eth1, so I assumed this was what I should be using. Thank you! – Brett Powell Mar 14 '12 at 13:33

Could you try removing NM_CONTROLLED=yes and restarting, see if that improves things?

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.