Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

With reference to this question: How do I access my public DNS on Amazon's EC2

If I configure my security groups acccording to Windows web platform firewall rules then is there an issue? Because when I did that I couldn't access the Public DNS on web browser.

  1. My security group is default and inbound rules are HTTP, RDP ,SMTPS, ICMP.

  2. My instance type is t1.micro webmatrix hosting server with default security group.

  3. My windows firewall is active for domain ,public and private profile.

  4. I am not sure about this point. Its HTTP port 80 as shown in my security group.

I am new to Amazon EC2 and this is really urgent.

share|improve this question
What are your security group settings? Port 80 should be open to, I'd imagine. – ceejayoz Mar 14 '12 at 13:37
Yes port 80 is open to – Aviral Kumar Mar 14 '12 at 13:40
Please add the following data: Security Groups associated with your accounts and their Inbound rules. Instance Type and the security group associated with the running instance ? Status of IPTables or Windows firewall or any firewall program running based on OS ? What is the server/daemon serving at port 80 ? – Shyam Sundar C S Mar 14 '12 at 13:59
Is UDP port 53 open? – Jeff Ferland Mar 14 '12 at 14:39
No it isnt...should i open it?? – Aviral Kumar Mar 14 '12 at 14:40

2 Answers 2

up vote 5 down vote accepted

If you are using the instance as a public DNS server then you will need to have UDP port 53 open in the instance firewall (if it has one) and in the Security Group that the instance is in.

Go to your AWS management console and Select EC2. Then Under navigation click on Network & Security -> Security Groups

Security Groups

In the Security Groups Pane select the group your instance is in (most likely default)

Select Group

Then In the lower pane click Create new Rule and select DNS

Select DNS

Then click Add Rule followed by `Apply Rule Changes. The EC2 security group will now allow DNS queries to your instance.

share|improve this answer
I dint configure for any firewall...but I just used UDP port what should I do?? – Aviral Kumar Mar 14 '12 at 16:04
I got my instance I used the elastic ip address to map with godaddy account. But the domain name isnt working – Aviral Kumar Mar 14 '12 at 16:17
Thanks for your answer Iain, it helped . I did it and now my instance is running and linked the elastic ip address with godaddy domain. How long should it take for my domain name to be active?? – Aviral Kumar Mar 14 '12 at 16:32

For developers working on Windows VPS, please ensure to add a custom rule for the specific port at which the server is running in Incoming Firewall rules. After adding custom rules for HTTP(port 8080), DNS(port 53) in Amazon EC2 security.

I had added incoming custom rule for port 8080 as my Apache tomcat server was running at port 8080 in Windows VPS.

Control Panel --->Windows Firewall ---> Advanced Settings Inbound Rules ---> Create a new rule and give the port at which the server is running

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.