Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Device: Cisco SR520W-FE

I have added a guest wireless network to this router but I can't seem to get nat overload to work with the new space.

LAN: 192.168.5.0/24 (VLAN 75) Guest WLAN: 10.5.5.0/24 (VLAN 50)

Here is the commands I'm using for the NAT overload

interface FastEthernet0
 switchport access vlan 75

interface FastEthernet3
 switchport access vlan 50

 interface FastEthernet4
 ip address x.x.x.x 255.255.255.252
 ip nat outside
 ip virtual-reassembly

interface Vlan50
 ip address 10.5.5.1 255.255.255.0
 ip access-group 120 out
 ip nat inside

interface BVI75
 ip address 192.168.5.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly

ip nat inside source list 10 interface FastEthernet3 overload
ip nat inside source route-map SDM_RMAP_1 interface FastEthernet4 overload

route-map SDM_RMAP_1 permit 1
 match ip address 101

access-list 10 remark PAT IP space for the guest WLAN
access-list 10 permit 10.5.5.0 0.0.0.255

access-list 101 deny   ip 192.168.5.0 0.0.0.255 192.168.76.0 0.0.0.255
access-list 101 permit ip 192.168.5.0 0.0.0.255 any

access-list 120 remark ACL to block guest wireless from LAN
access-list 120 deny   ip 10.5.5.0 0.0.0.255 192.168.0.0 0.0.255.255
access-list 120 permit ip 10.5.5.0 0.0.0.255 any
share|improve this question

2 Answers 2

It's been ages since I've done this, so my apologies if I missed something obvious, but... aren't you missing something like

ip nat pool "address of your external interface" ?

share|improve this answer
    
The LAN nat overload is currently working so I don't think that command is needed. I'm not sure if the "ip nat outside" command is what is making it work or not. –  evolvd Mar 14 '12 at 14:47
up vote 0 down vote accepted

The problem was that I was "NATing" the physical interface and not the SVI. Once I did that everything worked.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.