Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have just installed FreeNAS 7.3 in an Alix.2 board with 256 MB physical RAM on-board. Nothing configured, nor hard disks attached.

The problem is the OS is only using 51MB of that amount. The graph of the status page says that:

Memory usage: 78% of 51MiB

The output of sysctl confirms the previous value:

hw.physmem: 53604352
hw.usermem: 35471360
hw.realmem: 268435456

And is consistent whith data in /var/run/dmesg.boot (this one drifted a little bit):

real memory  = 268435456 (256 MB)
avail memory = 47779840 (45 MB)

How can I tell FreeNAS to use all available 256MB? Or what can be wrong with the FreeNAS-Alix mix?

I have tested with Voyage Linux and it seems to use all:

root@voyage:~# free -m
             total       used       free     shared    buffers     cached
Mem:           249         53        196          0          0         40
-/+ buffers/cache:         11        237
Swap:            0          0          0

From boot:

[    0.000000] Memory: 251716k/262144k available (2719k kernel code, 9980k reserved, 1111k data, 344k init, 0k highmem)
share|improve this question
    
I only know of three reasons this happens, and none of them seem likely in your situation. 1) Onboard video controller using the memory. 2) Incorrect BIOS settings making the memory unusable. 3) Kernel memory limitations. –  David Schwartz Mar 15 '12 at 4:26
    
@DavidSchwartz: Maybe I shoud try with another OS (probably Voyage Linux) and give feedback here. BTW, I'll poke around some TinyBIOS settings, but I'm not sure I'll get anything clear. Thanks! –  xOneca Mar 15 '12 at 15:02
    
@DavidSchwartz: I have discarded the first two points by installing Voyage Linux and seeing what info it gave (question updated with more info). Thanks again. –  xOneca Mar 15 '12 at 23:04
    
Yeah, that rules out the first two. The third seems kind of unlikely. I think you have a mystery on your hands. Sorry I can't be of more help. Is there anything else odd in the kernel messages? –  David Schwartz Mar 15 '12 at 23:05

1 Answer 1

up vote 1 down vote accepted

It seems to be solved in version 8.0.4 of FreeNAS. (i386 one, x64 does not seem to work for some reason...)

The problem with the newer version was I have a 1GB CF and the image is 2GB. I've solved it installing from the ISO onto the CF (using my PC).

It now kmows about all available memory!

real memory  = 268435456 (256 MB)
avail memory = 247967744 (236 MB)

Data from sysctl:

hw.physmem: 255295488
hw.usermem: 247279616
hw.realmem: 268435456

So the problem is with 7.3

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.