Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am working with racoon tool and ipsec-tools and I have been able to connect two devices with IPSEC working in transport mode. However, I did it with IPv4 addresses and when I change them to IPV6 addresses, it doesn't work.

Does anybody know if there is any difference between the configuration of IPv4 and IPv6?

Thank you

Configuration:

#racoon.conf

log notify;
path certificate "/etc/racoon/certs";

remote anonymous {
    exchange_mode main,base,aggressive;

    verify_cert on;
    my_identifier asn1dn;
    #my_identifier fqdn;
    certificate_type x509 "cert.pem" "key.pem";
    ca_type x509 "cacert.pem";
    lifetime time 24 hour ;

    proposal {
            encryption_algorithm 3des;
            hash_algorithm sha1;
            authentication_method rsasig;
            dh_group 2;
    }
}
sainfo anonymous
{
    pfs_group 2;
    lifetime time 12 hour ;
    encryption_algorithm 3des, cast128, blowfish 448, des, rijndael ;
    authentication_algorithm hmac_sha1, hmac_md5;
    compression_algorithm deflate;
}

Configuration:

#ipsec-tools.conf


flush;
spdflush;


spdadd 192.168.1.1 192.168.1.2 any -P out ipsec
    esp/transport//require
    ah/transport//require;

spdadd 192.168.1.2 192.168.1.1 any -P in ipsec
    esp/transport//require
    ah/transport//require;

spdadd 2002:1def::192.168.1.1 2002:1def::192.168.1.2 any -P out ipsec
    esp/transport//require
    ah/transport//require;

spdadd 2002:1def::192.168.1.2 2002:1def::192.168.1.1 any -P in ipsec
    esp/transport//require
    ah/transport//require;
share|improve this question

migrated from stackoverflow.com Mar 15 '12 at 9:18

This question came from our site for professional and enthusiast programmers.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.