Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've installed ISPConfig 3 on my VPS using the brilliant tutorial here: http://www.howtoforge.com/forums/showthread.php?t=56541

However, if I go to send an email to an account I've set up on the server I get the following error:

Delivery to the following recipient failed permanently: michael@gravex.co.uk

Technical details of permanent failure: DNS Error: DNS server returned answer with no data

I've checked my DNS records for that domain, and they are as follows:

setanta A       80.xx.xx.xx 
mail.gravex.co.uk   MX  10  80.xx.xx.xx
NS      ns1.6sync.net.  
NS      ns2.6sync.net.  
NS      ns3.6sync.net.  
ftp A       80.xx.xx.xx
mail    A       80.xx.xx.xx
dail    A       80.xx.xx.xx
www A       80.xx.xx.xx
.   A       80.xx.xx.xx

I've also tried to send an email from squirrelmail. I've had no errors come back but I've not had the e-mail come through either.

I'm not sure what's going on, as I thought adding mail.gravex.co.uk as an MX record would work, but I don't think it has. What do I need to do to make it work?

Cheers!

EDIT
I've changed the MX record so gravex.co.uk points to mail.gravex.co.uk. However, e-mails still can't be delivered to the account due to the same error.

Also, the DNS server is handled by 6sync, not ISPConfig 3.

share|improve this question

2 Answers 2

up vote 1 down vote accepted

@D_Bye is correct; you want to specify the MX record for gravex.co.uk not for mail.gravex.co.uk. A fully qualified domain name in a zone needs a dot after it. Also, MX records must point to domain names, not IP addresses, so:

gravex.co.uk.  IN  MX  10 mail.gravex.co.uk.

EDIT:

Just noticed that you're missing IN in each line:

setanta IN A       80.xx.xx.xx 
mail.gravex.co.uk. IN MX  10  80.xx.xx.xx
gravex.co.uk. IN NS ns1.6sync.net.  
gravex.co.uk. IN NS      ns2.6sync.net.  
gravex.co.uk. IN NS      ns3.6sync.net.  
ftp IN A       80.xx.xx.xx
mail IN A       80.xx.xx.xx
dail IN A       80.xx.xx.xx
www IN A       80.xx.xx.xx
gravex.co.uk. IN   A       80.xx.xx.xx

EDIT 2:

It's now just occurred to me that you pasted the output of a GUI you're using to edit the DNS record, not the record itself (because there are other parts missing). If this is the case, then setting the MX for gravex.co.uk to mail.gravex.co.uk should solve your problem.

share|improve this answer
    
Still no joy unfortunately! –  mickburkejnr Mar 15 '12 at 18:13
    
Using dig gravex.co.uk MX I see no MX records. Either it's still not right, or it may take a little longer to propagate. Are you able to edit the zone file directly or are you using a GUI? A paste of the whole zone file, or a screenshot of the GUI would be helpful. –  xofer Mar 15 '12 at 19:11

I think you need to remove the mail.gravex.co.uk from the MX entry - with it there, you tell the DNS how to handle mail for <user>@mail.gravex.co.uk, instead of <user>@gravex.co.uk.

share|improve this answer
    
I've changed it from mail.gravex.co.uk to gravex.co.uk, and changed the destination to go to mail.gravex.co.uk. Or should I just leave it as the IP? –  mickburkejnr Mar 15 '12 at 14:25
    
See nobody's answer - try the format suggested there. It's been a while since I edited a zone file, so my knowledge of the syntax is evidently a little rusty! –  D_Bye Mar 15 '12 at 14:33
    
Assuming you're using the ISPConfig GUI, and that it handles the important details (trailing dots, IN, etc.) you should be done -- setting the destination to a domain name is correct. –  xofer Mar 15 '12 at 14:46
    
I'm not using ISPConfig for DNS, I'm using 6sync.net's servers –  mickburkejnr Mar 15 '12 at 15:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.