Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Of late I have noticed that many of the commands respond to me in foreign language. According to Google translate it is Italian.(See screenshot)

Foreign texts in red boxes

I have noticed that this happens to me only when I ssh to some remote system, as in this case. When I access that system locally then it "replies" to me in English. I had noticed this same problem for another remote system too. At that time I had assumed that maybe that remote system's language setting is screwed. However, now it seems my local system (ssh) is somehow introducing itself in Italiano.

What is going on?

share|improve this question
1  
i have no idea what is wrong with your servers but this is quite funny... :D I'll be realy ungry if my remote servers start talking to me in i dont know ... Chinese :D –  B14D3 Mar 15 '12 at 18:44

1 Answer 1

up vote 4 down vote accepted

It seems to me that either you have a local environment variable which indicates that your language (or locale) is italian, or the remote servers have their default locale set to italian. Check if you have an environment var called LC_ALL or anything starting with LC_ (execute: set | grep ^LC_) which indicates that you're default locale is italian. Also, your ssh configuration may contain environment settings indicating the forementioned. Does it also happen when you ssh to localhost?

share|improve this answer
    
You are right. The output on my local is LC_ALL= LC_COLLATE=it_IT.UTF-8 LC_CTYPE=it_IT.UTF-8 LC_MESSAGES=it_IT.UTF-8 LC_MONETARY=it_IT.UTF-8 LC_NUMERIC=it_IT.UTF-8 LC_TIME=it_IT.UTF-8. How do I fix this? –  AppleGrew Mar 15 '12 at 19:35
1  
That depends on your local system. What type of system is it? Looking at your name, I'm guessing you're on OSX? –  Friek Mar 15 '12 at 19:36
1  
Yes. It is OSX. I found the settings in my ~/.bash_profile. I remember copying them there from the net to fix some issue I don't remember. Aaah, the perils of copy-paste. –  AppleGrew Mar 15 '12 at 19:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.