Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Just got a Supermicro X7SPE-HF-D525 and it's my first time trying IPMI. I can connect to the IPMI web interface and use IPMIView to connect, but as soon as I power up the machine, I lose connection (and can't ping the IP anymore). Am I missing something? The firmware I found on SuperMicro's site is the same number (255) as what the web interface says is installed.

One thing in my BIOS that doesn't match the manual, is I can't find a "*" next to any of the COM ports.

Make sure that the COM port for SOL (COM2 or COM3) is enabled (marked 4. with "*"). If not, Select the port for SOL and press . (For IPMI to work properly, the BIOS will set the console redirection on this port by default.)

share|improve this question
    
yes i also not found an option in the BIOS for embedded IPMI on supermicro motherboards. Anyhow I'll discuss this matter with my colleague and send back to you very soon! –  user118682 Apr 25 '12 at 11:04

2 Answers 2

up vote 4 down vote accepted

It looks like your machine comes with Integrated IPMI. This means that your BMC may be configured to use either the dedicated IPMI port on the back of the machine, or it may share IPMI with one of the existing LAN ports (This is called sideband).

Read the manual, and make sure that your system is configured to use either dedicated IPMI (This is my preference) or IPMI sideband. Make sure it is what you expect it to be.

The Supermicro BMC sometimes tries to autodetect the IPMI port, and sometimes makes the wrong decision. I've actually had to do the following to get IPMI working:

  1. Configure IPMI to use either dedicated IPMI or sideband IPMI.
  2. (This is the tricky part) Unplug power from the machine. Let the capacitors bleed. Simply powering off the machine is not sufficient, since IPMI is intended to work when your machine is powered off. In fact, Embedded_BMC_IPMI.pdf says:

    Note 1: If you wish to use the IPMI-dedicated LAN port for your network connections, be sure to connect an RJ45 cable to your dedicated LAN port before you activate the BMC (at fi rst power-on or cold reset). Otherwise, the BMC will look for a shared LAN port to connect to if the IPMI-dedicated LAN cable is not detected upon BMC activation.

  3. Plug in an ethernet cable into the correct IPMI port. The link layer must be active-- the other end must be plugged into an active port on your network switch. e.g. Electrons must be flowing over the wire, so that the BMC can detect an active link.

  4. Power the machine back on.
share|improve this answer
    
I don't see anywhere to select which port, or whether dedicated or sideband...? I could definitely let one be dedicated to IPMI. –  tladuke Mar 16 '12 at 0:13
    
It should be possible from the Web Interface, or you might need the boot from a USB drive and use the IPMICFG utility. Check for your appropriate manual (there are several. Start your search at supermicro.com/products/nfo/IPMI.cfm ) –  Stefan Lasiewski Mar 16 '12 at 0:25
    
I've not found an option in the BIOS for embedded IPMI on supermicro motherboards that allow you to configure which port the IPMI will use. It seems to use sideband always. –  Matt Mar 16 '12 at 1:10
    
So I gave up on installing from a network share and installed windows otherwise, and after installing the NIC driver, NIC1 has a IPMI IP and a Windows IP and I can use the remote control... –  tladuke Mar 16 '12 at 1:21

You can use ipmitool to select the port:

http://www.supermicro.com/support/faqs/faq.cfm?faq=9848

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.