Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to configure telnet server in windows 7.

When I try make a telnet connection from another machine within the LAN, and I log in with the username and password of a administrator account, I get a "Not all privileges or groups referenced are assigned to the caller." error.

I'm sure I missed out something but I'm not sure where it is!

share|improve this question
add comment

2 Answers

It sounds like you're running the Telnet Server as NetworkService.

As per - http://technet.microsoft.com/en-us/library/cc770898

Your token will be filtered of administrative privileges based on:

  • Whether you are using a local or domain administrative account
  • The value of the LocalAccountTokenFilterPolicy registry key
  • Whether the telnet service is running as LocalSystem or NetworkService

If you're running the telnet server as NetworkService, you will not be able to keep any administrative privs in your token.

You need to run the service as LocalSystem. If you're using a local account, you will also need that registry key to be set to a value of 1.

The registry key doesn't matter if you're using a domain account.

share|improve this answer
    
Is the registry key you are referring to this one --> HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\system LocalAccountTokenFilterPolicy = 1 (DWORD) ? –  tommi Mar 16 '12 at 16:53
    
Yes - same key as I mentioned in my first attempt to answer this (the one that's already set to 1). –  Adam Thompson Mar 16 '12 at 17:27
add comment

This sounds like a UAC thing.

I'm assuming you can probably logon just fine, it's just that you can't perform privileged operations - because your logon session isn't elevated. This is only a problem when you are logging on with a local account. If you telnet using a domain account which has admin privs, you should be OK.

In order to allow elevation for remote logon sessions with local accounts, you need to set a registry key, as described at The Vista Compatibility Team Blog.

The key is:

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\system
LocalAccountTokenFilterPolicy = 1 (DWORD)

I think you will need to reboot before it starts working.

share|improve this answer
    
It's already set to 1 :( –  tommi Mar 16 '12 at 15:40
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.