Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a server running Debian stable on which i keep my film archive at home.

Its been performing quite well for the past 6-9 or so months since i installed it, but for the last couple of days it has been very slow to provide my windows desktop with a directory listing of the films directory of one of the samba shares - it doesn't however affect any of the other folders on the share which are lightning quick as ever.

The folder in question has just recently gone over 2TB of data within and now windows properties on the folder reads 2.02TB. I don't think this has anything to do with the problem as i removed some files temporarily to test with the size less than 2TB and it hasn't made a difference, but i mention it for completeness.

Also probably not relevant, but mentioning for completeness. The server's disk configuration is 1 OCZ-Agility2 120GB SSD as system disk and 4 2tb Hdds which all have sequential serial numbers (as near identical as possible) for main storage. The 4 large disks are configured with md raid as a single raid5 device with no hot spare.

The share is called \SERVER\media and the folder in question is in the top level of the share and is called \Films .

I have tried rebooting the server and desktop to see if it was a temporary issue of some kind, but it doesn't appear to have had any effect.

I have double checked that i have not changed the samba configuration for over 6 weeks and this problem has only been showing itself for

So... I'm looking for suggestions of what i should try next or if it is a known limitation of a certain configuration.

In response to comments:

Samba version 3.5.6 File Count: 585 in 28 folders (within the Films folder that is) Avg file size is about 3.5 Gb and there's nothing smaller than 200Mb

Have checked dmesg, everything seems in order.

Forgot to mention. the folder can also be viewed locally as an apache directory listing. That is working as normal. So is listing the directory on cli. Only samba is experiencing slow problems.


Having tested with a friend's computer, it seems the issue lays with windows (why am i not surprised) - anyway If i access the share directly (using UNC path) from either system it is nice and fast as it ought to be however when i access the share through my mapped network drive it suddenly becomes very slow. So i unmapped and remapped the share on the same drive letter but it hasn't helped - however remapping to a different drive letter has helped.

I guess windows has cached something that it no longer likes. Anyone know how to clear that?

share|improve this question
    
What's the number of files in that directory? And what's the samba version? –  ott-- Mar 16 '12 at 21:54
    
it could be an issue with a block on the disk that contains those Films files. Check dmesg, /var/log/messages for any possible logs pertaining disk access issues. That's the only thing that comes to mind, as I had a similar problem but I was using USB HDD and eventually that HDD deteriorated within months. Some sections of the HDD were OK, while others were incredibly slow. –  Ben Ashton Mar 16 '12 at 22:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.