Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Although my XP workstations are connected to the domain, after booting firewall.cpl reports they're "using non-domain settings".

Official literature tells me it's an issue with the DNS suffix of its connection not matching the DNS name on the last group policy update, however this doesn't seem right as applying gpupdate /force correctly fixes it to "using domain settings".

How can I get the firewall to correctly detect it's on a domain upon boot?

share|improve this question
1  
Note that this problem (and the solution) apply to Windows Server 2003 as well as to XP. –  Harry Johnston Jul 13 '12 at 6:06

1 Answer 1

up vote 4 down vote accepted

I found the answer after scouring the net and thought to post my question and answer here to help others. Dave Nickason wrote:

On any workstation where the firewall is showing as using the non-domain settings, go into Services and set the Network Location Awareness service to start automatically, and then restart the workstation or do gpupdate /force. Setting NLA to automatic startup should fix it permanently. The issue is that with NLA set to manual, it starts too slowly to get the firewall to use the correct (domain) settings.

As far as I know, MS never documented this, but you'll notice that NLA is set to automatic by default in Vista.

Thanks Dave!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.