Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

With UFW, I disabled all outgoing and ingoing traffic by default. However, I do allow port 80 in and out:

  1. sudo ufw default deny incoming (deny all incoming)
  2. sudo ufw default deny outgoing (deny all outgoing)
  3. sudo ufw allow in 80/tcp (accept all incoming tcp from port 80)
  4. sudo ufw allow out 80/tcp (accept all outgoing tcp to port 80)

Yet, the following commands don't seem to work. Could anyone tell me why?

mainuser@saturn101:~/apps/mongodb$ curl http://fastdl.mongodb.org/linux/mongodb-linux-i686-2.0.4-rc1.tgz > mongodb-2.0.4-rc1.tgz

curl: (6) Couldn't resolve host 'fastdl.mongodb.org'

And,

ping google.com
ping: unknown host google.com

And,

sudo apt-get update
share|improve this question
add comment

2 Answers 2

up vote 2 down vote accepted

You didn't enable DNS traffic (TCP/UDP outgoing, port 53) and UDP 1024-65535 outgoing (also required for DNS.

share|improve this answer
    
Excellent, apt-get update seems to be working without UDP 1024-65535 outgoing though. When is this really necessary? –  Tom Mar 17 '12 at 16:21
    
FYI, I have posted a follow up question –  Tom Mar 17 '12 at 17:48
    
Outgoing to port 53 UDP and TCP is sufficient for DNS. Restricting the source to 1024-65535 for this rule is optional. –  BillThor Mar 18 '12 at 0:43
add comment

The correct syntax would be

sudo ufw allow out to any port 53

This resolves problem with DNS

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.