Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm at a loss as to why this extension is not being found. See the screenshot for why I'd be a tad confused as to why it's not working.

enter image description here

As you can see in the screenshot, the extension directory in the php.ini file (left window), the directory in the error message when I start up the wampserver (center window) and the directory that contains the extension are all the same. But it's still not found. Is there some other setting that I'm not aware of that needs to be set to get this working? I know that the extension directory is labelled correctly as changing it sets off a barrage of errors of unfound extensions instead of just the one.

Enviroment is windows XP, SP3. wampserver 32bit, in an oracle virtualbox VM

share|improve this question
    
Permissions, file corruption, solar flares... could be a lot of things. –  womble Mar 18 '12 at 3:09
    
@womble perhaps I should call a young priest and an old priest –  canadiancreed Mar 18 '12 at 3:24
1  
The problem is that once they'd finished their work, you'd have a blank disk. –  womble Mar 18 '12 at 3:33
    
Ironically I've tried a new VM. Still same f'in problem. –  canadiancreed Mar 18 '12 at 3:44
    
Longshots are long but- Any chance that the file could be 64b? Could the difference in version numbers be the cause? –  qweet Mar 18 '12 at 14:16
show 1 more comment

1 Answer

try adding PHP to your PATH in Env Variables. can't you make that php folder name simple just "php" instead of php5.3.10

Have a look at this site
http://php.net/manual/en/install.windows.extensions.php

share|improve this answer
    
Didnt' make a difference. If it was a path issue, my understanding is that none of the extensions loaded on startup would work, as it wouldn't see the php dir. All the extensions load,except for the one that I need. –  canadiancreed Mar 18 '12 at 14:10
    
make sure to keep a copy of php.ini in windows folder, it actually solved my problem a long. Btw now i use php with IIS those problems seems to be fixed now :) –  kgthenerd Mar 18 '12 at 18:42
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.