Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

System: Windows 2008 SP2 Standard Version 64Bit

Network Card: only 1

Object: Set up VPN

Guide: http://blog.thesysadmins.co.uk/server-2008-r2-pptp-vpn-with-1-nic.html

Problem: How come I can only see VPN and Dial up options in the Wizard, and Not be able to choose Custom Config and others?

Screenshot: Windows 2008 Missing options in RRAS

share|improve this question

2 Answers 2

up vote 2 down vote accepted

The reason you don't see the same options as in the guide, is because the guide applies to Windows Server 2008 R2, while you use Windows Server 2008 with SP2. They are 2 distinct operating systems.

For information on setting up VPN on Windows Server 2008, check out the deployment guides at TechNet

share|improve this answer
    
awesome - Thanks. –  starchx Mar 19 '12 at 6:37
    
This is a non-answer. You never explained why; you merely pointed out the obvious version differences. For what it's worth, I have a 64-bit Windows Server 2008 R2 box that has the same issue as the OP. Your answer is not only inaccurate, it's disingenuous and misleading. –  diz Jul 14 at 19:27
    
@diz If you have any relevant information that surpasses my non-answer in ingenuity, please feel free to exercise the limited democratic power the "Add Another Answer" button possesses, and shame my misleading answer by way of a better one. –  Mathias R. Jessen Jul 14 at 21:43
    
The purpose of my comment was to inform others who mistake your answer for a solution and subsequently waste the time to reinstall with R2 only to encounter the same problem, as I did. I'm still unable to find a solution to my issue despite days of scouring Google as well as the MSDN forums. Since you provided no information supporting your position, I can only assume you made it up. I could be wrong, but I have a limited set of credible information with which to go on. Rest assured, if I find a solution, I will not hesitate to follow up. –  diz Aug 14 at 20:52

Despite Mathias's insistence otherwise, I encountered this same issue with R1 and R2. What I did to bypass the "less than two network interfaces" restriction was to add another network adapter.

  1. Control Panel
  2. Open up Device Manager
  3. Select Action | Add legacy hardware
  4. Choose "Install the hardware that I manually select from a list"
  5. Select "Network adapters" from the hardware types
  6. Select "Microsoft" for the Manufacturer
  7. Select "Microsoft Loopback Adapter" for the Network Adapter

After the loopback adapter is installed, you can proceed with selecting the "VPN" option in the RRAS setup. After setup, you can remove the loopback adapter and the RRAS service will continue to function.

I have no idea why the other options are not visible. Fortunately, this trickery worked to bypass the inane restrictions that Microsoft built into this "Wizard".

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.