Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I was upgrading the openssh-server package using apt-get upgrade on my Ubuntu 7.04 server, in order to fix the debian PRNG security bug. I was doing so over an SSH connection (putty on windows) which I thought was ok but...

The upgrade seems to have hung at the following, it's like it wants me to click "Ok" in the "window" but of course I can't because I'm just in a shell.

Setting up openssh-server (4.3p2-8ubuntu1.5) ... Package configuration

âââââââââââââââââââââââ⤠Configuring openssh-server âââââââââââââââââââââââââ
â                                                                           â
â Vulnerable host keys will be regenerated                                  â
â                                                                           â®
â Some of the OpenSSH server host keys on this system were generated with   â
â a version of OpenSSL that had a broken random number generator. As a      â
â result, these host keys are from a well-known set, are subject to         â
â brute-force attacks, and must be regenerated.                             â
â                                                                           â
â Users of this system should be informed of this change, as they will be   â
â prompted about the host key change the next time they log in. Use         â
â 'ssh-keygen -l -f HOST_KEY_FILE' after the upgrade has changed to print   â
â the fingerprints of the new host keys.                                    â
â                                                                           â
â The affected host keys are:                                               â
â                                                                           â
â
â                                  <Ok>
â                                                                           â
âââââââââââââââââââââââââââââââââââââââââââââââââââââââââââââââââââââââââââââ

I notice that I can't connect any new ssh sessions to the server anymore, but an existing one I have open still works.

Any ideas how I can proceed?

share|improve this question
add comment

1 Answer

up vote 6 down vote accepted

Ensure the Putty window has focus, then try hitting "Enter". If that doesn't work, hit "Tab" until the "< Ok >" is highlighted and then try "Enter" again.

share|improve this answer
    
Sweet, thanks! I had tried hitting "Enter" many times, and practically every other key, but never considered "Tab". Tab to select, then Enter, worked like a charm!! –  M. Lucas Jul 7 '09 at 16:07
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.