Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have 2 OEL5.5(RHEL5.5) servers. I'm trying to figure out why when I run mount command I get different outputs.

Server1 has the following line in /etc/fstab/      /exports     nfs     _netdev,rw,bg,hard,nointr,tcp,vers=3,timeo=600,actimeo=0,rsize=32768,wsize=32768,async 1 2

Server2 has the following line in /etc/fstab/      /exports     nfs     _netdev,rw,bg,hard,nointr,tcp,vers=3,timeo=600,actimeo=0,rsize=32768,wsize=32768     1 2

When I run mount on Server1 I see on /exports type nfs (rw,bg,addr=

When I run mount on Server2 I see on /exports type nfs (rw,bg,hard,nointr,tcp,nfsvers=3,timeo=600,actimeo=0,rsize=32768,wsize=32768,addr=

Why does Server2 show more parameters? Does it mean it's mounted differently?

share|improve this question
Hm. Can you also check with cat /proc/mounts? Sometimes the kernel's idea of mount options differs from the one reported by mount. – Marius Gedminas Mar 19 '12 at 16:47
server1 shows cat /proc/mounts /exports nfs rw,vers=3,rsize=65536,wsize=65536,hard,proto=tcp,timeo=600,retrans=2,sec=sys,add‌​r= 0 0 server2 shows cat /proc/mounts /exports nfs rw,vers=3,rsize=32768,wsize=32768,acregmin=0,acregmax=0,acdirmin=0,acdirmax=0,ha‌​rd,proto=tcp,timeo=600,retrans=2,sec=sys,addr= 0 0 – Mxx Mar 19 '12 at 19:32
The rsize and wsize are incorrect on server1 – Ryan Babchishin Oct 8 '15 at 22:06
This is a good question. Have you tried mounting it from the command line? Maybe try it with different mount options too. – Ryan Babchishin Oct 8 '15 at 22:07

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.