Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I need to change selinux to "permissive mode" on a production server without a reboot, but setenforce wont let me do it(as a root), it always prints "setenforce: SELinux is disabled" What i'm doing wrong?

[root@server3 ~]# setenforce 0
setenforce: SELinux is disabled
[root@server3 ~]# setenforce 1
setenforce: SELinux is disabled
[root@server3 ~]# setenforce Permissive
setenforce: SELinux is disabled
[root@server3 ~]# getenforce
Disabled
share|improve this question

migrated from stackoverflow.com Mar 20 '12 at 5:38

This question came from our site for professional and enthusiast programmers.

    
Might have something to do with SELinux hooking into the kernel? Sounds plausible to me, perhaps someone will know for sure. –  SpacemanSpiff Mar 20 '12 at 5:42
    
If selinux is disabled at boot the machine will have to be reoboted in order to enable it again. –  Matthew Ife Mar 22 '12 at 15:45

1 Answer 1

up vote 2 down vote accepted

setenforce can only be used to change the mode SELinux is running in. It cannot be used to enable SELinux.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.