Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I mainly do web design but I host a few client sites on a Centos 5 VPS.

A new client has asked me to host their site and I've been given the following configuration requirement:

Apache 2.2.3 
PHP 5.2.17 
MySQL 5.0.77 
Image Magick 6.5.1-0 (not as an Apache module) 
Ghostscript 8.7

Checking php_info() I have:

Apache 2.2.3
PHP 5.2.14
MySQL 5.0.90

I don't have IM or GS listed.

I expect that my versions of PHP and MySQL are similar enough to work, but how do I get my server set up to work with this client's site as well?

share|improve this question
add comment

2 Answers 2

up vote 1 down vote accepted

The current ImageMagick in the C5 repositories is ImageMagick-6.2.8.0-12.el5, which might be worryingly down-rev for you; yum list ImageMagick ghostscript to see those.

If the client is hard-and-fast about their minimum versions, you might be better off with C6 (apache 2.2.15, php 5.3.3, mysql 5.1.52, ImageMagick 6.5.4, ghostscript 8.70). If they want those exact versions, you're in for a lot of compilation fun.

share|improve this answer
    
Thank you. It'll only be too down-rev for me if the site doesn't work, so I'll check out the differences. –  user114671 Mar 20 '12 at 11:47
    
Upgrading to C6 will impact all my sites, so I don't really fancy that today - I need a strong coffee and a clear diary to take that on! –  user114671 Mar 20 '12 at 11:52
add comment

They are in separate packages. In my Ubuntu:

$ apt-cache search ghost | grep php
php5-ps - ps module for PHP 5

$ apt-cache search magick | grep php
php5-imagick - ImageMagick module for php5
share|improve this answer
    
Thanks, I'll check them out on Centos. –  user114671 Mar 20 '12 at 11:53
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.