Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

The setup: WHM/CPanel CentOS 5 server running Exim and Courier for mail services, and BIND for domain name services.

I recently moved servers. The old server was running a HIGHLY similar configuration, and all accounts were ported via WHM. However, the server is unable to send, and sometimes receive email.

Errors I am seeing (when I do get an error mail back) state:

450 4.1.8 : Sender address rejected: Domain not found

Edit for clarity: this is the error response from remote mail servers. Numerous independent mail servers come back with the same error.

(Email address is merely one valid example)

My first instinct of course was to check the domain records. However, k-t.org appears to have a valid record (including an MX record), even after running it through domain checks on a completely different server elsewhere and online. Note that the issue appears to happen with all the domains hosted on the server, not just k-t.org

I have also ensured that a PTR was created.

My Googling has only lead me to people who had fairly basic DNS mistakes, but either I'm blind/dumb (possible, DNS is not my strong suite), or it's something that is a bit more archaic. I've run out of ideas, and I can't seem to find anything that could explain why servers are unable to resolve the domains. There doesn't seem to be anything missing or incorrect.

share|improve this question
    
What is the name of your server? If you have it generically named or not a mappable name, then this could be some of the problems. –  kobaltz Mar 20 '12 at 16:27
    
It is named server.sorrowind.net which has an A record in the sorrowind.net complete DNS record. I should add that sorrowind.net is also the home of the nameservers (ns1/ns2). –  user1281413 Mar 20 '12 at 17:18
add comment

1 Answer

It's not a DNS issue. Your exim hasn't been configured to receive mail for that k-t.org domain.

Take a look at:

http://www.exim.org/exim-html-3.20/doc/html/spec_43.html

I'm not familiar with cPanel, so I don't know if that's something you would configure through cPanel.

Update:

OK, it's a different issue: I just did an SMTP transaction against k-t.org, sending to postmaster@k-t.org (Subject: Test message), which was accepted.

Since I'm able to retrieve DNS records for the MX and the A for the MTA, it's time to look at the remote server. Do they have stale DNS records?

share|improve this answer
    
I'm not sure you understand the issue. My exim service isn't receiving the mail. My server is sending the mail, and the remote server is returning with that error message. Exim is most certainly configured to receive mail for k-t.org (along with every other domain), as this is part of how CPanel works with Exim. –  user1281413 Mar 20 '12 at 17:04
    
I've updated my response. The next step is to check for stale DNS. –  cjc Mar 20 '12 at 17:21
    
I have no idea if they have stale records. This issue occurs for probably 90% of all mail servers on the internet, not just a single one (GMail is an example of an exception to the rule). I wouldn't know how to even check if their records are stale. It's been well over 24 hours since the last major DNS change occurred. Thanks for walking through this. –  user1281413 Mar 20 '12 at 17:25
    
Hmm. So, from where I'm sitting, WHOIS and DNS look correct. TTL is 4 hours, so 24 hours is more than enough time. Were the TTLs different before the last DNS change? –  cjc Mar 20 '12 at 17:39
    
No, they've been the same for many, many days. –  user1281413 Mar 20 '12 at 17:46
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.