Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am administrating a VPS running cPanel and I'm trying to install postfix. Redhat-release says the version is CentOS release 6.2 (Final) and uname -a says:

Linux server.mydomain.com 2.6.32-220.el6.i686 #1 SMP Tue Dec 6 16:15:40 GMT 2011 i686 i686 i386 GNU/Linux

This is how I'm installing postfix (I had tried to solve the problem earlier by installing epel).

# yum install postfix
Loaded plugins: fastestmirror, security
Loading mirror speeds from cached hostfile
 * epel: mirror.cogentco.com
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package postfix.i686 2:2.6.6-2.2.el6_1 will be installed
--> Processing Dependency: mysql-libs for package: 2:postfix-2.6.6-2.2.el6_1.i686
--> Finished Dependency Resolution
Error: Package: 2:postfix-2.6.6-2.2.el6_1.i686 (centos-burstnet)
           Requires: mysql-libs
 You could try using --skip-broken to work around the problem

Attempts to install mysql-libs tells me several files conflict with "MySQL-server-5.1.61-0.glibc23.i386"

I'm not sure why or how this is happening, does anyone know how to resolve this? Surely Centos 6.2 could not have shipped with a broken postfix.

share|improve this question
    
May I ask why you installed MySQL-server-5.1.61-0.glibc23.i386 instead of installing mysql-server-5.1.61-1.el6_2.1.i686 via yum? –  Lars Rohrbach Mar 21 '12 at 5:23
    
It was already there in the VPS, I'm not sure who installed it or why. –  Mishari Mar 21 '12 at 7:49
    
You do understand that cPanel control panel is an extremely tightly knit software where installing other programs such as a SMTP server(Postfix) can break emails/functioning of the cPanel. –  Swapneel Patnekar Mar 21 '12 at 11:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.