Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

For some reasons, I cannot connect to my SQL Server with full name + instance name (e.g. server_name\MSSQLSERVER) by SMSS. However, I can connect by simply using just server_name or localhost.

When I check SQL server configuration manager, I did see my sqlserver is running with "SQL Server (MSSQLSERVER).

share|improve this question
    
In configuration manager, have you enabled named pipes? –  Thor Erik Mar 21 '12 at 7:08
add comment

3 Answers

Looks like your running a default instance, you dont need to connect using hostname\instancename, hostname is enough

share|improve this answer
add comment

The default instance servicename is MSSQLSERVER, but the instance name is empty (just the servername).

This may occur (rarely) when you are not using the SQL Browser Service and are running on a non-standard port; in that case, the instance name alone is not sufficient to reach the instance.

A non-default instance has the Windows service MSSQL$INSTANCENAME; the default is (oddly) MSSQLSERVER (no $).

share|improve this answer
    
Correct, the instance you have installed is the default instance so you will connect using only the server name. If you want to connect with server\instance then install another instance of SQL. –  Jason Cumberland Mar 21 '12 at 13:47
add comment

Instances have to be enabled to make this work (during setup, not sure if its possible to enable this afterwards). If instances are not enabled, the only availiable (single) instance will be the default.

Also see http://support.microsoft.com/kb/265808 for more information about connecting to instances.

Edit: see also the comment by Thor Erik, you can enable named pipes afterwards it seems :)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.