Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Just ran php -v on my Centos 5 server and got the following message back.

Failed loading /usr/lib64/php/modules//php_ioncube_loader_lin_5.1_x86_64.so:  /usr/lib64/php/modules//php_ioncube_loader_lin_5.1_x86_64.so: undefined symbol: zend_unmangle_property_name_ex
PHP 5.2.17 (cli) (built: Jan  7 2011 10:39:29) 
Copyright (c) 1997-2010 The PHP Group
Zend Engine v2.2.0, Copyright (c) 1998-2010 Zend Technologies

PHP seems to be running okay, but I don't like the look of that message. What does this message mean, and what should I do? (I don't want to upgrade to 5.3 as some client sites still use deprecated in PHP 5.3 functions.)

share|improve this question
add comment

1 Answer 1

up vote 2 down vote accepted

For me it seems you have an incompatible version of ioncube installed. I have never used ioncube, but I would guess that if you have updated PHP after installing ioncube, you might need to reinstall it ... however that happens. Just a wild guess. :)

share|improve this answer
    
Spot on, thank you. For reference I just used yum install php-ioncube-loader and it's all sorted. –  user114671 Mar 21 '12 at 12:42
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.