Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Trying to install do the following on Centos 5:

[root@d ~]# pecl install imagick

I got the following output:

downloading imagick-3.0.1.tgz ...
Starting to download imagick-3.0.1.tgz (93,920 bytes)
.....................done: 93,920 bytes
13 source files, building
running: phpize
Configuring for:
PHP Api Version:         20041225
Zend Module Api No:      20060613
Zend Extension Api No:   220060519
/usr/bin/autoconf: /usr/bin/autom4te: /usr/bin/perl: bad interpreter: Permission denied
/usr/bin/autoconf: line 271: /usr/bin/autom4te: Success
ERROR: `phpize' failed

Is the bad interpreter the problem? Is this causing phpize to fail? Or are these two separate problems?

share|improve this question

1 Answer 1

up vote 2 down vote accepted

Permission denied to Perl? Do you have SELinux enabled or something else funny going on? Have you done something odd such as chmod 000 /usr/bin/perl?

share|improve this answer
    
Many thanks again Janne. I have no idea how perl had 000 but I've set it to 755. –  user114671 Mar 21 '12 at 13:46
    
@user114671: Again? :) Did I help you before? Whatever, have a nice day! :) –  Janne Pikkarainen Mar 21 '12 at 13:52
    
    
OK, still, have a nice day :) –  Janne Pikkarainen Mar 21 '12 at 14:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.