Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have the FTP service running on Server 2003, and I am hosting websites through Apache. I have users configured to point to certain directories on the server. I am using FileZilla to remote FTP, but it never seems to connect to the directory.

The command window says:

Command: USER wayne
Response: 331 Password required for wayne
Command: PASS: *****
Response: 230 User wayne logged in
Status: Connected
Status:  Retrieving directory isting...
Command:  PWD
Response:  257 "/wayne" is current directory
Command:  TYPE I
Response:  200 Type set to I.
Command:  PASV

And that's it. It doesn't display any directories at all, and the pane says "Not connected to any server". Sometimes it will display the folder, but nothing happens when I click on it to expand it. It was working fine, and I have another FTP server set up the same way that does work.

How can I fix this?

EDIT: I've tried changing it to Active FTP, and it says:

Command:  LIST
Command: 150 Opening BINARY mode data connection for /bin/ls
Response:  425 Can't open data connection.
Error:  Failed to retrieve directory listing.

I also noticed that I'm not able to browse the site in IIS's management console anymore, it just shows a blank screen when I click on one of the names and says There are no items to show in this view, although the name has permissions to view the folder and everything. Could it be because I have the Web Publishing service disabled (as I'm not using IIS to host websites)? That shouldn't cause anything should it?

share|improve this question
add comment

2 Answers 2

Try setting your connectivity mode to Active rather than Passive. The thing about passive FTP is that is will attempt to connect to a random port which, most of the time, will be blocked by a firewall.

share|improve this answer
add comment

This seems to be a problem similar to http://serverfault.com/questions/37083/fault-when-setting-up-ftp-server-under-xp/37100#37100

When it works with active FTP, it most assuredly is, otherwise just check whether you can enable the raw commands that will show you the PORT command sent by the server.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.