Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am setting up a new 2008 SQL server on Windows 2008 R2 and it requires .NET framework 3.5. Unfortunately when I go to Features in the server manager, it only lists 3.0 and it is already installed. Our WSUS has all required and security updates enabled.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

So, download it from Microsoft... ? You don't see it in your WSUS because it's neither required nor a security update, I'll wildly guess.

Although, this is odd. Wikipedia tells me that 3.5 is the default in 2008 R2. Are you sure you've got R2?

share|improve this answer
    
I don't think there is a Disk 2 for 2008 R2, you're thinking 2003 R2. For 2008 R2 .Net 3.5 is there, you need to add the feature using the server manager. –  Coding Gorilla Mar 23 '12 at 19:43
    
I have just been doing 2003 R2 installs, you're entirely correct that 2008 R2 is a single DVD image. My bad. –  mfinni Mar 23 '12 at 19:52
    
But as Brian says, he's in Server Manager looking at Features, so I'm not sure what he's missing. –  mfinni Mar 23 '12 at 19:53
    
Yea, I think you're right, I think he's actually got 2008, not R2. –  Coding Gorilla Mar 23 '12 at 19:54
    
No, its definitely 2008 R2. I ended up doing what mfinni suggested and downloaded manually from Microsoft instead of enabling it locally on our WSUS –  Brian Mar 26 '12 at 19:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.