Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm pretty to new server admin and especially nginx but seem to be getting ok fine apart from accessing my mail via my iPhone?

I've changed my domain to 'domain.com'

The thing is I can send mail via my outgoing IMAP server but can't connect to the incoming one? I just get the message "the mail server at mail.domain.com is not responding"

/etc/postfix/main.cf

alias_database = hash:/etc/aliases
alias_maps = hash:/etc/aliases
append_dot_mydomain = no
biff = no
broken_sasl_auth_clients = yes
config_directory = /etc/postfix
home_mailbox = Maildir/
inet_interfaces = all
inet_protocols = all
mailbox_command =
mailbox_size_limit = 0
mydestination = domain.com, mail.domain.com, localhost.com, , localhost, localhost.localdomain
mydomain = domain.com
myhostname = mail.domain.com
mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128
myorigin = /etc/mailname
recipient_delimiter = +
relayhost =
smtp_tls_note_starttls_offer = yes
smtp_tls_security_level = may
smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
smtpd_sasl_auth_enable = yes
smtpd_sasl_local_domain =
smtpd_sasl_security_options = noanonymous
smtpd_tls_CAfile = /etc/ssl/certs/cacert.pem
smtpd_tls_auth_only = no
smtpd_tls_cert_file = /etc/ssl/certs/smtpd.crt
smtpd_tls_key_file = /etc/ssl/private/smtpd.key
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_security_level = may
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom

telnet localhost 25 > ehlo locahost

250-mail.domain.com
250-PIPELINING
250-SIZE 10240000
250-VRFY
250-ETRN
250-STARTTLS
250-AUTH LOGIN PLAIN
250-AUTH=LOGIN PLAIN
250-ENHANCEDSTATUSCODES
250-8BITMIME
250 DSN

Using the following details to connect:

username password hostname: mail.domain.com port: 25

iptables --list

Chain INPUT (policy ACCEPT)
target     prot opt source               destination

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination

I also sent mail to the server as a test and got this missage if it helps?

Technical details of temporary failure:
[mail.domain.com. (10): Connection refused]

I also looked in /var/log/mail.log and it has multiple entries of:

postfix/smtpd[12239]: connect from 5acefc9a.bb.sky.com[90.206.252.xxx]
Mar 23 06:47:09 new-domain postfix/smtpd[12239]: lost connection after CONNECT from 5acefc9a.bb.sky.com[90.206.252.154]

Notice new-domain which is incorrect but the server hostname and hostname in the configs are correct? I recently moves servers and the host has set the primary domain on the service as new-domain.com so this may be the issue?

Like I said, it works to connect to outgoing server, but incoming gets the not responding error? Any idea would be much appreciated!

share|improve this question

1 Answer 1

up vote 5 down vote accepted

By "accessing my mail via my iPhone" do you mean receiving mail on a client? This usually uses either POP3 or IMAP, not SMTP, and Postfix is not a POP3 or IMAP server. You'd need something like Dovecot to provide POP3 or IMAP access for clients.

share|improve this answer
    
Sorry my bad, IMAP...I'll update the question and look into dovecot. thanks for the reply :) –  daveaspinall Mar 23 '12 at 23:15
    
After re-configuring postfix, installing dovecot and setting them all to work with an sql database of aliases I've managed to get everything working via POP3 which will do me for now! Thanks for the nudge in the right direction :) –  daveaspinall Mar 24 '12 at 0:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.