Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We have a cyrus 2.4.12 on Debian, we use packages, rather than building each software ourselves.

I am getting the this "log" constantly, a lot of, various users, and 8-10 times per user request:

fetching user_deny.db entry for 'user123'

I have searched for it, but haven't found a real solution, there were some patches for 2.3.xx, but we don't want ot build it, we prefer to use packages.

Is there any solution to disable the user_deny.db at all. We don't need this feature. It wastes the CPU as disk.

share|improve this question

3 Answers 3

I would switch to syslog-ng and filter out this message by configuring:

filter f_imapd { facility(local6) and level(debug) and not match("regexp" value("fetching user_deny.db entry for")); };

share|improve this answer

If you use syslog-ng, you can also try suppress identical messages with suppress configuration option:

options {
 suppress(30);
};

In this example identical messages will be logged once per every 30 seconds

share|improve this answer

Seems the correct filter syntax is:

filter f_imapd { facility(local6) and not match("fetching user_deny.db entry for" value("MESSAGE")); };
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.