Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Django 1.4 was recently released. Almost all the information about Django 1.4 is in the release note, but I didn't see anything about how to upgrade. Should I just remove the django folder inside Python's site-packges and download 1.4? I think I originally installed Django using emerge and yum but I'm not sure if the package management systems are up-to-date with Django 1.4 yet.

That might be ok on my server instance (Gentoo Linux), but on my local instance I am using virtualenvwrapper (on Mac OS 10.7), so maybe I want to create a new Python virtual environment for Djago 1.4. Or maybe not since I don't really care about backward compatibility with 1.3.1.

share|improve this question

1 Answer 1

up vote 1 down vote accepted
  1. Create a backup
  2. Someone suggested on stackoverflow:

I usually create a symlink from my Python site-packages directory to the Django version I am using. When I change versions I merely change the symlink to point at the right version. Here is the documentation for creating a symlink. The docs mention the development version but you can do it for any version.

Original question.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.