Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

This is a fresh linode Ubuntu 10.04 LTS vps. I am trying to install postfix, but I get weird character encodings in the package config and cannot choose options. I had the same thing with mysql but ignored it since I could still type in the root password, but here I cannot choose the setting I need.

This is what I see

share|improve this question

1 Answer 1

up vote 1 down vote accepted

In your terminal, echo $TERM and compare this to the settings that you're using in whatever terminal program you're running. They should basically match so that the server knows what the capabilities of your terminal program are, and can send the right types of special characters and signals for screen drawing.

If your terminal is emulating, say, xterm, then, when you ssh into the VPS, you should run export TERM=xterm (or whatever your terminal program is emulating).

share|improve this answer
    
Thanks for the help. I changed the character set in putty to UTF-8 and it works now! –  Errol Fitzgerald Mar 25 '12 at 11:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.