Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I installed the latest mantis .deb package from the Debian package repository: mantis_1.1.6+dfsg-2_all.deb

How can I access the mantis application?

This server is already used for a wiki, so when I try

http://wiki/mantis/

an empty wiki page appears.

Update:

Below is the wiki's configuration file in the site-available folder. I am guessing that I need to place something similar to RewriteCond RewriteCond %{REQUEST_URI} !^/mantis in there:

<VirtualHost *>
        #ServerName dekiwiki

        ErrorLog /var/log/apache2/error-dekiwiki.log
        CustomLog /var/log/apache2/access-dekiwiki.log common

        DocumentRoot "/var/www/deki-hayes"

        RewriteEngine On
        RewriteCond %{REQUEST_URI} ^/$
        RewriteRule ^/$ /index.php?title= [L,QSA,NE]

        RewriteCond %{REQUEST_URI} !^/(@api|editor|skins|config|deki)/
        RewriteCond %{REQUEST_URI} !^/index\.php
        RewriteCond %{REQUEST_URI} !^/favicon\.ico$
        RewriteCond %{REQUEST_URI} !^/robots\.txt$
        RewriteCond %{REQUEST_URI} !^/error/(.*)\.var$
        RewriteCond %{QUERY_STRING} ^$ [OR] %{REQUEST_URI} ^/Special:Search
        RewriteRule ^/(.*)$ /index.php?title=$1 [L,QSA,NE]

        # Bug: 5252 https rewrite/proxy rules
        RewriteCond %{HTTPS} =on
        RewriteCond %{REQUEST_URI} ^/@api/
        RewriteCond %{QUERY_STRING} !^(.*)dream.in.scheme= [NC]
        RewriteRule ^/@api/(.*)$ http://localhost:8081/$1?dream.in.scheme=https               [QSA,P,L]

        RewriteCond %{HTTPS} =on
        RewriteCond %{REQUEST_URI} ^/@api/
        RewriteCond %{QUERY_STRING} ^(.*)dream.in.scheme= [NC]
        RewriteRule ^/@api/(.*)$ http://localhost:8081/$1 [QSA,P,L]
        # End Bug: 5252

        # deki-api uses encoded slashes in query parameters so AllowEncodedSlash              es must be On
        AllowEncodedSlashes On

        # FIXME:
        # Some php flags we need. These are only needed until all
        # the short php open tags are changed to long in the source code.
        php_flag short_open_tag on
        # Allow short open tags and turn off E_NOTICE messages
        php_value error_reporting "E_ALL & ~E_NOTICE"
        # Setting php memory parameters
        # php_value memory_limit "128M"
        # php_value post_max_size "64M"
        # php_value upload_max_filesize "64M"

        # mod_proxy rules
        ProxyPass /@api http://localhost:8081 retry=1
        ProxyPassReverse /@api http://localhost:8081
        SetEnv force-proxy-request-1.0 1
        SetEnv proxy-nokeepalive 1

        <Proxy *>
          AddDefaultCharset off
          Order deny,allow
          Deny from all
          Allow from all
        </Proxy>
</VirtualHost>

<Directory "/var/www/deki-hayes">
        # Possible values for the Options directive are "None", "All",
        # or any combination of:
        #   Indexes Includes FollowSymLinks SymLinksifOwnerMatch ExecCGI MultiVi              ews
        #
        # Note that "MultiViews" must be named *explicitly* --- "Options All"
        # doesn't give it to you.
        #
        # The Options directive is both complicated and important.  Please see
        # http://httpd.apache.org/docs-2.2/mod/core.html#options
        # for more information.
        Options None
        # AllowOverride controls what directives may be placed in .htaccess file              s.
        # It can be "All", "None", or any combination of the keywords:
        #   Options FileInfo AuthConfig Limit
        AllowOverride All
        # Controls who can get stuff from this server.
        Order allow,deny
        Allow from all
</Directory>

#
# DirectoryIndex: sets the file that Apache will serve if a directory
# is requested.
#
<IfModule dir_module>
    DirectoryIndex index.html index.php
</IfModule>
share|improve this question

2 Answers 2

up vote 2 down vote accepted

The wiki's website has a FAQ that explains what I was missing. I just needed to include the mantis folder in one of the RewriteCond lines to exclude that folder from the wiki.

How do I...Install PHP apps on the VM?

share|improve this answer

aptitude install mantis

cat /etc/apache2/conf.d/mantis

So have you hacked your apache config not to include the /etc/apache2/conf.d files ? I suspect that you need a separate virtual server for mantis as the Wiki is intercepting what you would expect to got to the mantis system.

Do you have these two lines in /etc/apache2/apache2.conf

# Include generic snippets of statements

Include /etc/apache2/conf.d/

# Include the virtual host configurations:

Include /etc/apache2/sites-enabled/

share|improve this answer
    
In the apache2.conf file, I see the "conf.d" and the "sites-enabled" lines. The "/etc/apache2/conf.d/mantis" also exists. In the "/etc/apache2/sites-available" folder, I only see a file for the wiki's configuration, and it hasn't been changed for a long time. –  lamcro Jul 8 '09 at 11:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.